I am trying to get the ar command on an embedded ARM computer running linux. I want to install debian and openjdk. It is a headless system. This is a custom linux distribution provided by the hardware manufacturer.

The debian installer is missing the ar command so i tried copying the binaries from the debian package, but when running ar I get error while loading shared libraries: libbfd-2.18.0-multiarch.20080103.so: cannot open shared object file: No such file or directory

libbfd is also in the package. I tried linking it to /lib and /usr/lib but I get the same message when running.

What is the best way to get debian and ar on a custom linux distro?


The loader uses the hints provided by ldconfig to look for shared libraries, as well as a couple of well-known places (/lib and /usr/lib, modified appropriately for the platform).

  • ok. Only problem is ldconfig is not available on my box – Esben Skov Pedersen May 6 '10 at 11:14
  • I found the problem. The symlink was broken and I didn't notice because the shell highlighted it in a color indicating a good link. – Esben Skov Pedersen May 6 '10 at 11:30
  • You can also check out the /etc/ld.so.conf file (used by ldconfig) and the LD_LIBRARY_PATH environment variable. – David May 6 '10 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.