I fiddled around with the virtual network settings of my Hyper-V server, because Windows Update failed to run in the VMs. I set the flag that makes the NIC exclusively usable by the VM. Now, the host system tells me it has no active network adapters.

What does that even mean? According to netsh, there are three enabled network connections. I tried to restart the NICs using devcon.exe (the correct x64 version), but that doesn't make any difference - still, devcon reports the NICs are there and they are activated?!

Is there any way I can force the host (using the console) to re-enable the NICs?


Undo your change.

I set the flag that makes the NIC exclusively usable by the VM

Logically - if the NIC is reserved exclusively for the VM, obviously the host can not use them anymore.

Open the settings for the Hyper-V networks you created. you can turn them on there for the host, too (so that the host and the VM's can use them).

  • Sorry, my question was not precise (updated): I can't access the Hyper-V manager, because that requires a working network connection already. I can only access the console on the Hyper-V Server directly. So I need to do that using the console. I guess there is a registry key or some other tool, but I couldn't find any information on that. – mnemosyn May 10 '10 at 11:05
  • Out of luck here ;) Plug in another network adapter to access the server (anyone should have one lying around). I think you effectively locked yourself out. – TomTom May 10 '10 at 11:07
  • There must be some registry keys, but I don't know them. What server? Hyper-V server doesn ot even have a nice registry editor. Faster to reinstall, I think. – TomTom May 10 '10 at 11:07
  • Hm, I see :( I guess I'll just install Windows Server 2008 and use VMs hosted by it. I feel Hyper-V administration is a major pain by now, all the tools seem to be highly immature (if they exist at all). Certainly, I'm unexperienced w/ Windows administration, but this type of problem should not occur ever. Where is the red button I can press locally? darn Thanks for your help! – mnemosyn May 10 '10 at 11:12
  • 1
    Thing is, Hyper-V Server just like ESXi and so on are meant to be treated like appliances and not server installations. If you mess up, just reinstall the appliance OS - it should be quick and painless. – Oskar Duveborn May 10 '10 at 11:15

I locked myself out of the server by making the nic exclusively usable by the VM. To make the NIC also usable by the management OS you can use the following in PowerShell:

Set-VMSwitch -Name "YourName" -AllowManagementOS 1

If you do not know the names of your virtual switches, you can use:


Since you already solved the problem by rebuilding this isn't helpful to solve it - but for future problems, most of Hyper-V is manageable through WMI and you could have solved the problem that way.

Rather than getting into the details of that though, I will link you to the Powershell Management Library for Hyper-V, which is a sweet Powershell based wrapper around the WMI calls. You could have used it to remove the NIC from the VM and that should have given you your access back. Get it installed now before you have future problems...

  • Thanks, that looks very good! Reinstalling didn't take long, but I appreciate this a lot for potential future problems - reinstalling feels bad if there is actually data present... I don't understand why this is not an integral, not to say the integral part of the distribution, but I guess that question is out of scope ;) – mnemosyn May 10 '10 at 17:17

This error can occur if you uncheck, "Allow management operation system to share this network adapter" from within 5Nine Manger. Get local console to the HyperV server and run the following powershell commands. Change "External" to match your switch name.

GET-VM | GET-VMNetworkAdapter | Connect-VMNetworkAdapter –Switchname "External"
Set-VMSwitch -Name "External" -AllowManagementOS 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.