I have some HP Compaq T20 Thin Clients connecting to a Windows Server 2003. Now I want to upgrade to 2008 R2, so I tested a trial installation with remote desktop in administration mode.

So I try to connect my T20 to the server and... It doesn't matter if I turn off encryption or not it disconnects with an generic error instantly.

The T20s have Windows CE embedded with RDP 5.2 installed.

Out of curiosity I tried Windows Server 2008 (no R2) and it worked! I tried the same with a Windows 7 machine set up with-> no work.

I can not update the T20s to Windows NT embedded for example because they only have a low amount of flash memory.

It seems the "new" version of RDP coming from Windows 7 / Windows Server 2008 R2 is completely incompatible with the older 5.2 version.

People are having the same problem here: http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/700488cd-a872-47e5-85a7-595f050afc10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.