The company I work for recently got hands on a batch of second hand PowerEdge SC1425 machines. We'd like to put these to good use. Our operating system of choice is Ubuntu Server 10.04 64-bit, which installs just peachy on this type of machine.

Now I'd like to install the firmware updates from Dell, which are apparently marked as recommended. This includes the updates for the BIOS, the BMC, and possibly some other hardware.

I find it incredibly difficult to locate the files on the Dell website, and install any of them on an Ubuntu system:

  • I downloaded the file OM_6.2.0_SUU_A01.iso.
    • I believe I've read that the SUU DVD should be able to update any recent PowerEdge. Is this correct?
    • Is this the latest version? Besides the version number, does A01 have any meaning?
    • Is this image bootable? (At the moment, I just nosed around with a loop device mount.)
  • Running /bin/bash ./suu from the DVD, I get:

    # /bin/bash ./suu
    ./suu: line 262: ./java/linux/i386/bin/java: No such file or directory

    The file exists and is executable, though. But I cannot execute it directly from the shell either.


I'm not sure it's what you're looking for, but I tend to upgrade PowerEdge systems using the OMSA live CD from the OpenManage Dell site. I just boot it up (it's centOS-based), downloaded the needed upgrade files for Red Hat, run them, and then reboot back to the original system.

| improve this answer | |
  • This seems to have worked just fine. I don't believe I actually used any of the tools on the CD, but the live environment was good enough to run SUU from the loop mounted image. Thanks for the pointer! – Shtééf May 11 '10 at 12:51
  • @Shteef - oh, so you mean those round things that come with servers are not alternatives for cork coasters? they are one of the first things that go to the trashcan during unboxing of a new server. – pQd May 11 '10 at 15:38

The file exists and is executable, though. But I cannot execute it directly from the shell either.

You are likely missing the 32-bit compatibility libraries, preventing the 32-bit Java from executing. In the documentation, it explicitly states that SUU is a 32-bit application and what the dependencies are for running in a 64-bit environment.

These are the dependencies as documented for Red Hat. I suppose that they ought to be available for Ubuntu under the same or similar names; procmail, glibc, compat-libstdc++-296, compat-libstdc++-33, libstdc++, zlib, and libxml2.

I know this question has long since been answered, but it took me a while to figure it out so I am answering for the benefit of others that may be searching this question.

| improve this answer | |
  • It's been a while, but I wouldn't be surprised if that was my problem. I never thought 'no such file or directory' could mean that. – Shtééf Feb 16 '11 at 8:09
  • You wouldn't think, but you know the file does exist because you can see it. Error handling isn't always written well enough to give the most descriptive feedback. If you get a chance, try it and let us know since it could help others with the same problem. – Aaron Copley Feb 16 '11 at 15:57

The Fine Manual worked for Ubuntu 12.04 LTS on a Dell PowerEdge 2850. I didn't even have to use the kernel boot option reboot=bios. No fussing with floppy disk images, dosemu, or other wackiness.


The instructions lists where to get the raw BIOS on the linux.dell.com website.

| improve this answer | |
  • The link is 404'ed. Wish folks would copy the content to SF instead of linking to it. – a coder Nov 1 '14 at 18:59

you will need to mound the image with -o exec to enable execution of the application from that dvd (or iso image)

| improve this answer | |
  • 1
    I didn't find this necessary at all. – Aaron Copley Feb 15 '11 at 17:51

I always burn the SUU to disk and boot to it. From there you can navigate the Dell menus, scan for needed firmware updates, and install them. Reboot and you are good to go.

| improve this answer | |
  • The SUU has OS and RAID config items on the same menu as the firmware. That is pretty ambiguous to me. When you "apply", does it modify the raid or start prepping for an OS install? I have a fully configured OS I don't want the SUU to anything except update firmware. – iPaulo Mar 2 '11 at 14:42
  • You are talking about the Systems Management and Configuration disk if you see those options. In that utility you have 3 options. Firmware, which you connect to a repository, the RAID config, and then the OS config. The SUU disk has a repository and is for firmware updates. # ./suu -u – Chadddada Mar 2 '11 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.