2

When I use Tortoise SVN on a samba drive inside virtualbox it is exremly slow... is there anyway to config samba to make it any faster? On a local drive it is very fast so it is not the svn server.

2
  • Why are you checking out to a network drive in the first place?
    – Ryan Bair
    May 11 '10 at 18:44
  • 1
    Because the app only runs in linux but the dev enviroment windows..
    – user42816
    May 12 '10 at 12:59
2

Make sure that traffic on the following ports is allowed to the host running Samba.

TCP: 139 445
UDP: 135 137 138

I inserted the following lines into smb.conf file under [global].

read raw = No
write raw = Yes

Seemed to speed things up quite a bit. The page linked to below should help. There's a bit on the TCP_NODELAY socket option which is apparently a fantastic option to set.

http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/speed.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.