i have successfully installed CouchDB 0.11 on Ubuntu 10.04 based on the Installation instruction in couchdb wiki for ubuntu 10.04. with appending " --bindir=/usr/bin --sbindir=/usr/sbin --localstatedir=/var --sysconfdir=/etc" in ./configure

And CouchDB is running successfully and got " {"couchdb":"Welcome","version":"0.11.0"}"

But the Test Suite is not running successfully, with being freeze in the first task "basics".

Any support to solve that and making the Test Suite running smoothly on Ubuntu 10.04.

  • The same happened to me, looking at the quearies with wireshark, it stops on a simple map function, I wonder why – chmeee May 13 '10 at 12:53
  • also i got form localhost:5984/_status response {"error":"error","reason":"illegal_database_name"} while all databases names is so normal. – ShenoudaB May 13 '10 at 14:05

I experienced the same issue, with the Test Suite freezing on the first "basics". CPU was very high and the log was littered with logs like this

[Wed, 26 May 2010 17:34:18 GMT] [debug] [<0.1014.0>] OS Process Start :: #Port<0.2005>

[Wed, 26 May 2010 17:34:18 GMT] [debug] [<0.1014.0>] OS Process
#Port<0.2005> Input  :: ["reset",{"reduce_limit":true}]

[Wed, 26 May 2010 17:34:18 GMT] [error] [<0.786.0>] OS Process Error <0.1014.0> :: {os_process_error,{exit_status,127}}

I was able to fix the issue when I ran couchdb manually, with LD_LIBRARY_PATH set to the lib directory for xulrunner-devel, which was one of the prerequisites I believe.

# export LD_LIBRARY_PATH=/usr/lib/xulrunner-devel-
# /usr/local/bin/couchdb

All tests ran successfully when started like this.

EDIT: A more permanent fix is to add the above xulrunner-devel path to a file under /etc/ld.so.conf.d. On my machine I made a file /etc/ld.so.conf.d/couchdb.conf with the contents


Then I ran ldconfig and restarted CouchDB.

Sidenote: When I previously started CouchDB manually I did it as root, which caused some permission issues, so make sure that all permissions are set correctly where you installed CouchDB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.