Using PsExec v1.96 and given the below command:


I get the below error:

Couldn't access
Windows cannot find the network path. Verify that the network path is correct and the destination computer is not busy or turned off. If Windows still cannot find the network path, contact your network administrator.

  • 1
    What is the rest of the command? What you posted is incomplete and doesn't tell us what you were trying to run. – John Gardeniers May 14 '10 at 7:47
  • Try checking the firewall settings on the remote client. Try turning the target's Windows Firewall off temporarily to see if it makes a difference. Also make sure the Remote Registry service is running on the remote client. – Carl C Nov 3 '10 at 21:54
  • Are you able to ping remote PC? are you able to access admin shares on remote PC? – user106666 Oct 26 '12 at 6:24

Target is missing. Please try


Also the command you want to execute is missing at the end.

  • Sorry I tried in the rigth one like psexec \\HOSTNAME -u ADMIN_USER_NAME -p ADMIN_PWD hostname.Got the same error. In some system the same is working fine ! I check the remote services all are fine. – Navan May 17 '10 at 6:22

From the description of psExec, it is a client process and needs to connect with a server process on the remote machine. In fact it is called that - 'Server' process.

Go to your remote machine and open Services. Scroll down the list of services to find one called 'Server'. Make sure it is enabled and started.

  • You have really no idea how it works.Only RPC and admin share IPC$ needs to be enabled on remote PC.Voting down – user106666 Oct 26 '12 at 6:23
  • @rkosegi Wrong. – HopelessN00b Nov 5 '12 at 19:22
  • @HopelessN00b : If wrong, then explain.You are wrong if agree with this answer.Realy.Looks like you have no real programming experience with DCE/RPC and remote management, so you have never created such program.Please give some reference for your "wrong". – user106666 Nov 6 '12 at 5:34
  • BTW, psexec will not need this 'server' because it will create him first time if not exist.How? using RPC to service control manager. – user106666 Nov 6 '12 at 5:36
  • @rkosegi I don't know what you think you're talking about, but bullet point #3 in the PSExec FAQ is [on the target machine, check that] the Server service is running (check using services.msc). So, yes, the Server service is a requirement of PSExec, and for that matter, most of the SysInternals tools. There's a link to the FAQs for both in my answer, which I highly recommend you visit before making any more votes or declarations on the subject. – HopelessN00b Nov 6 '12 at 14:15

Since we're getting a bunch of wrong answers by new users bumping this anyway, let's try a complete answer on for size.

  1. You're using it wrong. It requires a target computer. And a target file to execute on that computer. From the output of psexec /?:

    • PsExec executes a program on a remote system, where remotely executed console applications execute interactively.

    • Usage: psexec [\\computer[,computer2[,...] | @file]][-u user [-p psswd][-n s][-l ][-s|-e][-x][-i [session]][-c [-f|-v]][-w directory][-d][-<priority>][-a n,n,... ] cmd [arguments]

  2. There's a FAQ for this, and it's a damn near sure bet you're missing one of the PSExec requirements.
    • For your case, it's most likely that the administrative share (C$) is not reachable or disabled, a firewall is blocking communications over SMB (Windows file and printer sharing service), the previously mentioned services are disabled in the remote machine, or you have the Server service (under services.msc) disabled.
    • See here for more PSExec-specific requirements that you may be missing.

You should install File and Printer Sharing for Microsoft networks (in Local area network Properties) at target computer, it will solve your problem

  • Uh, no. That's incomplete to the point of being wrong. – HopelessN00b Oct 26 '12 at 1:29
  • +1, If psexec can not copy it's binary to remote system due to no interface accept SMB, it can cause problem. – user106666 Nov 6 '12 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy