4

I recently rebuilt my machine to Windows 7 x64, installed Sql Server 2008 enterprise. I can connect fine to other remote instances via Management Studio (be they 2000, 2005 or 2008), but i cannot find my local default instance.

  • I have verified that a directory was created for the default instance C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER
  • I can connect to SQLEXPRESS instance fine
  • I have rerun setup to ensure I have everything installed
  • I have verified that the SQLSERVER(MSSQLSERVER) service is running
  • I have verified that SQL Server Browser is running
  • I have tried brownsing for the instance and see all the others available except my local one
  • I have tried using this for servername: TSOUTHERLANDPC\MSSQLSERVER, the first part being my local machine name

My issue is not the same as this post or this post.

Any ideas?

1
  • cant figure out how to post another answer even tho I have enough reputation... but would like to offer my resolution Nov 9, 2011 at 6:23

5 Answers 5

3

re-install sql server. I had the same problem and then noticed that instead of installing a local instance I installed a named instance ( that just so happened to be the same name as a local instance). For some reason there is a difference between a local instance with the exact same name as a local instance and when you actually choose local instance.

4
  • seriously? ugg.. There is no way to setup a default instance if you chose named instance during install? And I very well could have done as it's been a few weeks since I installed.
    – Tone
    May 14, 2010 at 21:00
  • You can do another install, if there is no default instance already installed, you will have an option to add a default instance. Once you get things straightened out, just disable the service for the named instance.
    – SqlACID
    May 14, 2010 at 22:09
  • i uninstalled just sql server, and reinstalled selecting the default instance but still get same thing, guess my next step is to uninstall every last bit of it. I am running Win7 x64 and installed SQL server x64.
    – Tone
    May 15, 2010 at 2:22
  • i uninstalled completely and reinstalled but the Developer edition this time (still R2). I think I chose enterprise the first time around b/c I didn't feel like downloading the developer edition from msdn. works fine now. thanks!
    – Tone
    May 16, 2010 at 2:11
3

Try your hostname followed by the instancename, for instance PC\SQLEXPRESS

2
  • Right I've tried that. SQLEXPRESS works fine, but MSSQLSERVER, which is the default instance, does not.
    – Tone
    May 15, 2010 at 16:50
  • I tried MYMACHINE\LOCAL and got in finally. Running developer version of 2008 R2. Thanks for the suggestion.
    – user70163
    Feb 9, 2011 at 19:15
1

Check the configuration manager and make sure the browser is running.

1
  • SQL Server Browser is running.
    – Tone
    May 14, 2010 at 19:03
1

The instance name that you should use for the default instance is the hostname of your machine, so try just tsoutherlandpc and see if that does it for you.

2
  • I get login failed when I try that. I'm using windows auth.
    – Tone
    May 14, 2010 at 21:01
  • after a complete reinstall, and using the developer edition this time, this approach works.
    – Tone
    May 16, 2010 at 2:10
1

As stupid as this sounds, open SQL Management Studio by using Right Click -> Run As Administrator.

You should now be able to connect to your default instance.

This is a wonderfully undocumented 'feature' that occurs on any of the newer Windows OS' with UAC enabled.

1

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .