I have a pretty weird problem. We have setup an SVN-Mirror via cronjob (because it needs to go from inside to outside of a firewall, so no post-commit-hook possible) and svnsync. We installed a pre-revprop-hook just as told.

Everything seems to work fine, except that it doesn't.

E.g. when manually executing the script.

# svnsync --non-interactive sync file://<path-to-mirror> --source-username <usr> --source-password <pwd>
Committed revision 19817.
Copied properties for revision 19817.

No error, no complaints. But if checking for the revision properties it says:

# svnlook info <path-to-mirror>

# svn info -r HEAD file://<path-to-mirror> 2>&1
Path: <root-of-mirror>
URL: file://<path-to-mirror>
Repository Root: file://<path-to-mirror>
Repository UUID: <uid>
Revision: 19817
Node Kind: directory
Last Changed Rev: 19817

So somehow the author and timestamp information gets lost. But we need that information for our internal processes. Since no error or warning is produced I have absolutely no idea even where to start to look. Everything is local (except for the remote master), so there are no server-logs to look at.

I also tried to manually recopy via svnsync copy-revprops (http://chestofbooks.com/computers/revision-control/subversion-svn/svnsync-Copy-revprops-Ref-svnsync-C-Copy-revprops.html). It says

Copied properties for revision 19885.

But when I query them, it's just the same.

Any ideas how I could approach that problem, or even better -- how to solve it? Any ideas appreciated.


After some fiddling with it, we found the answer... it was a permission problem. The user used to create the backup had readaccess on the repository level via

mirror = r

but on some if not most subdirectories, that was overwritten via

* = 

Strange thing is that the tool svnsync did not complain about it, like it did when the password was incorrect. And the revisions where copied too, only the properties made problems...

We solved the problem by adding a

mirror = r

on every folder...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.