0

I'm trying to install sql server 2008 express but it fails I'm using web platform installer.

I recieve the following error:

Install exit code for product 'SQL Server Express 2008 with Service Pack 1' is -2067529723

why ? what to do ?

  • do you have service pack1 installed on u r machine? – Malcolm May 17 '10 at 7:14
  • check this out forums.iis.net/t/1158408.aspx Do you have any other version of sql server on your computer? Do you have visual studio installed? If yes, what versions? – hgulyan May 17 '10 at 7:14
2

look in the log file in "c:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log" or equivalent to your system - look through Detail.txt backwards and look for errors there.

| improve this answer | |
  • That pretty much is it. Many possible culprits, including already having it installed. – TomTom Oct 9 '10 at 7:55
1

Best solution I found was here: http://support.microsoft.com/kb/954835 - see Alternate Workaround Steps

Basically, install SQL Server and the latest SP on another machine (preferably XP, I used XP mode on my own machine). Then install SQL Server on YOUR machine.
When you get to the point where it fails to start the SQL service, copy the Sqlservr.exe and Sqlos.dll files from the BINN folder on the successful machine into your machine. Then click Retry and the service should start.

This is the only thing that worked for me from dozens of other suggestions.

| improve this answer | |
1

This problem is still relevant for SQL Server 2014, with the exact same error code (-2067529723). I'm trying to upgrade SQL Server 2012 Express to SQL Server 2014 Express and got an instant crash when running the Setup.exe file.

I'm on a Windows Server 2012 instance on an ESXi host, from other posts about this problem that actually might be relevant.

With a bit of fluke I found out that the %TEMP% environment variable for some reason was pointing to a non-existent path, since the path it pointed to ended with '\2', e.g. C:\Users\username\AppData\Local\Temp\2.

To test this: hit Windows+R for Run command, type %TEMP% and hit Enter. If you get an error message saying that a folder cannot be found, you have the same problem.

I solved it by manually creating the \2 subfolder and then the setup started just fine.

| improve this answer | |
0

See this thread: http://social.msdn.microsoft.com/forums/en-US/sqldatabaseengine/thread/caac8741-4db9-488a-aef6-998a0eede2f5/

First make sure that you are a Administrator on the Remote Server. As per http://msdn.microsoft.com/en-us/library/ms143219.aspx:

For local installations, you must run Setup as an administrator. If you install SQL Server from a remote share, you must use a domain account that has read and execute permissions on the remote share.

Then make sure that you are running the setup.exe from the DVD root, and not the setup100.exe from inside one of the installer folders like x86/x64/ia64. If this fails, download CU2 for SQL Server 2008, and run it first, which will install an updated setup and support files, then rerun setup.

| improve this answer | |
  • he is installing from web platform installer, so mindless pasting the section about DVD root is not OK – Axarydax May 17 '10 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy