I had 5.4 machine. Upgraded to 5.5 today via yum upgrade. All went fine. Rebooted. Wanted to convert root partition to ext4 (I have three partitions: /boot, / and swap). All of them on software RAID 1 (root is /dev/md2). I did the following for converting

yum install e4fsprogs
tune2fs -O extents,uninit_bg,dir_index /dev/md2
nano /etc/fstab # I indicated here that my /dev/md2 is of ext4
uname -a
mkinitrd -f /boot/initrd-2.6.18-194.3.1.el5.img 2.6.18-194.3.1.el5

Rebooted. I expected fsck to start automatically as said on some site. But it did not. Threw some error (don't remember exactly which). Ok, I booted linux rescue and executed fsck:

fsck -t ext4 -fy /dev/md2

Partition went fine. But still when I boot main system, it says in log: "ext3-fs:" then something about not being able to mount ext3 partition due to unknown extended attributed (200).

I booted linux rescue again. It loads fine and correctly determines all my machine partitions both ext3 (boot) and ext4 (/) under /mnt/sysimage just fine.

I retried mkinitrd thing again watching it's output and ensured ext4 module is included into the system. I also edited menu.lst grub file to include rootfstype=ext4 kernel parameter. Bad luck. I still have message from ext3-fs about not being able to mount filesystem because of attributes and kernel panic immediately after. I checked /etc/fstab - it's fine and saying that root is of ext4.

What did I do wrong? This machine is empty so I can just reformat it with 5.5 and recreate partitions to be originally ext4. But... I just want to know what did I do wrong.

  • Posting the kernel message would help with the debugging. Have you tried the fsck with -D as per the upgrade instructions at ext4.wiki.kernel.org/index.php/… ?
    – jneves
    May 20, 2010 at 5:10
  • The problem is not in fsck. But in the fact, that initrd refuses to detect root filesystem as ext4 despite all my tries. May 20, 2010 at 9:45

2 Answers 2


I solved the problem. It was because mkinitrd was called without --with=ext4 option. I posted detailed article to my blog.


My apologies at the less that entirely helpful nature of this message, but I would definitely just reformat the machine if you can. For one thing, I believe that migrating ext3 to ext4 does not give you much/any of the fancy performance benefits that tend to be behind such a migration. You need a fresh ext4 file system to reap those benefits of the new file system layout. You could do this either through cloning the data onto another LV (if you're using LVM) or by a fresh install. YMMV as to which is the simplest for your case.

  • Yes, file system conversion with tunefs and fsck does not give you all benefits of ext4. But running e4defrag after - should do the trick. Since I have no solution so far, tomorrow I will reformat the server. But still I am interested in where I made a mistake... May 19, 2010 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .