I'm having a problem accessing phpMyAdmin.

A few weeks ago I did succeed configuring it for auth_type = 'cookie', but I still receive an error stating that I should have to set blowfish_secret. That was strange because it was set.

So I changed auth_type from cookie to http, but it didn't work. I changed it back to cookie, but it doesn't work anymore.

this is the error.

phpMyAdmin - Error

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

this is my C:\wamp\apps\phpmyadmin3.2.0.1\config.inc.php


/* Servers configuration */
$i = 0;

/* Server: localhost [1] */
$cfg['Servers'][$i]['verbose'] = 'localhost';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPassword'] = false;
// EDIT:
// $cfg['Servers'][$i]['blowfish_secret'] = 'this is my passphrase';
$cfg['blowfish_secret'] = 'this is my passphrase';

/* End of servers configuration */

$cfg['DefaultLang'] = 'en-utf-8';
$cfg['ServerDefault'] = 1;
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';


I changed the blowfish_secret, since I don't remember the old one, and I deleted the cookies in my browser and restartd all wamp services and the browser. After I enter username and password in the login page I get the error.

I've tried searching into the log files, but I'm a newbie and I'm not sure I've searched the right ones.

I'm using Wamp server 2.0 that has Apache Version : 2.2.11
PHP Version : 5.3.0
MySQL Version : 5.1.36
phpmyadmin :


I've changed to auth_type='config' setting username and password, then accessed phpmyadmin with success. Then I changed again to auth_type='config', using the same config file as above and it works again.
But now at the end of phpmyadmin main page I get the error:

The configuration file now needs a secret passphrase (blowfish_secret).

that is nonsense, since the blowfish_secret is set.


I've solved the last problem changing configuration line to set the blowfish_secret. See the above configuration just after // EDIT

  • Do you run a chrooted httpd? – Maxwell May 20 '10 at 14:37
  • @Maxwell: I don't know: I've installed the wamp 2.0 and didn't change any Apache configuration. How can I find if I'm running a chrooted httpd? What does it means? – sergiom May 20 '10 at 16:03
  • Obviously that is not your case, a chroot is a operation that changes the root directory for process, in that case the directory for storing the sessions may need to be recreated inside the chroot with proper permissions. – Maxwell May 21 '10 at 7:18

I don't think blowfish_secret is a per-server setting. It should just be:

$cfg['blowfish_secret'] = 'this is my passphrase';

And from the phpmyadmin error, it sounds like there might be something wrong with PHP's session configuration. If you can't find anything in the apache error log, make sure PHP is set to log errors by checking these values in php.ini:

error_reporting = E_ALL & ~E_NOTICE
log_errors = On

You might also try clearing your browser cookies associated with phpmyadmin (I just solved a separate login issue by doing this).

| improve this answer | |
  • Thank you for your answer. The php.ini error_reporting and log_errors where already set but I didn't find any useful entry in C:\wamp\logs\apache_error.log. I've already deleted all localhost cookies, which includes phpmyadmin cookies. – sergiom May 20 '10 at 16:09
  • Use php.ini-recommended for wampp installation. check the php.ini file location via phpinfo() then replace all session directives with default values in php.ini-recommended file. & also check the session save path variable. set it correctly to use a writeable directory. – risyasin May 20 '10 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.