I'm having a problem with SQL Server 2005 where the SQL Server Agent suddenly refuses to start. If I attempt to start it through Services, I get the error "SQL Server Agent (MSSQLSERVER) service on Local Computer started and then stopped." In the Application log, I have the following entry:

Event Type: Error
Event Category: Service Control 
Event ID:            103
Date:       5/20/2010
Time:       11:07:07 AM
User:       N/A
Computer:            SHAREPOINT
SQLServerAgent could not be started (reason: Unable to connect to server 'SHAREPOINT'; SQLServerAgent cannot start).

This database has been running fine for four months. It contains a SharePoint configuration database, which two days ago stopped working, throwing me a message that the configuration database cannot be reached. It was then that I realized the SQL Server Agent was not running, and I have been unable to restart it. I have tried running it with both the local system account and the network service account, with the same results. So far, I have tried:

  • Granting the administrators group, network service, and SharePoint SQL Server Agent account public and sysadmin roles on the database.
  • Granting the administrators group, network service, and SharePoint SQL Server Agent account full permissions to the entire MSSQL directory and all files within.

I still have no joy.

  • is the VIA protocol running?
    – Campo
    May 20, 2010 at 16:26
  • Have you rebooted the machine yet? What other trouble shooting steps have you taken?
    – aduljr
    May 20, 2010 at 16:43
  • Is the SQL Server itself running? SQL Server agent needs SQL Server to be running... May 20, 2010 at 16:55
  • VIA is not installed at all, and I've restarted a few times with no luck. I'm really not even sure where to go from here.
    – Geo Ego
    May 20, 2010 at 17:00
  • Yes, SQL Server is running fine, and I am using the same account for it as I am trying to for the SQL Server Agent.
    – Geo Ego
    May 20, 2010 at 17:01

2 Answers 2


It looks like this site has some troubleshooting steps you can try:



You could try running ProcMon from SysInternals, filtering out that particular process, and seeing where it's failing: i.e. is it having DNS issues? Missing registry key? You'll see some low-level errors that may help you isolate what the issue is.

  • Thanks for the advice. I don't use ProcMon much, but I just tried it and SQLAGENT90.EXE is throwing tons of NAME NOT FOUND errors and buffor overflows. I don't really know which are important, but one that sticks out is the NAME NOT FOUND error on the "HKLM\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo" key. I don't have that key in the registry and it seems like I should. Overall, there are about a thousand errors thrown by SQLAGENT90.EXE and the vast majority are NAME NOT FOUND and BUFFER OVERLOW. It's overwhelming. Do you have a suggestion of which ones to start with?
    – Geo Ego
    May 20, 2010 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.