I've just got in a few Windows 7 (64, Windows 7 Professional) machines, and I'm trying to get the AIK 2010 working.

I've set up one of the machines, and installed AIK and MDT on it. I've followed the directions at http://technet.microsoft.com/en-us/library/dd349348%28WS.10%29.aspx about 3 times now, and also tried the built-in .chm help files that came with AIK.

In AIK I grab the install.wim image off the OEM cd, at which point it asks me which version (I select Professional). I follow the rest of the instructions creating a new Autounattend answer file, and fill in the various bits and pieces according the the step-by-step guides.

I verify the Answer file (No warnings or errors), save it, and copy it onto a USB drive. I go to another machine, insert it's OEM Win7 Disk, and power on. I've set BIOS to boot from CD, so it goes directly into the installation. Once The files are loaded, and Setup starts, it immediately asks which version to install (Home basic, Home Premium, Professiona, Ultimate). Ugh, I thought it was supposed to be an automated install, and that selecting the Version when opening the .wim file would answer this question. I looked for an option to set which version to be installed on the net, in the help, and in AIK itself; to no avail.

Anyway, just for laughs I select Professional,and hit continue. It copies files for about 10 seconds, then fails with the following error: "Setup was unable to create a new system partition or locate an existing system partition. See the setup log files for more information. [OK]". Clicking OK reboots the box, and obviously there are no log files because the OS isn't installed.

It is a Dell Optiplex 380 , Intel Core Duo 2.93 GHzl 4 GB RAM, 64 Bit.

Any help would be REALLY appreciated.


I got the installation started.

In my haste/frustration I changed the BIOS priority of the USB drive to where it shouldn't be. The only guess is that when starting the installation, the installer was looking at the USB drive as the target location (even though when set to always show UI in Autounattend.xml, the partition tool showed the HD, not the USB key??).

It is still giving the option to select OS Version, though, which I don't get. Could this possibly be a result of not including the product key in the Autounattend.xml? - I don't have a WVL server setup and it would be overkill in this instance; I plan on entering the keys manually.

  • Where did you get an ISO with Home Basic, Home Premium, Enterprise, and Ultimate all on the same disc? Enterprise and Ultimate are basically the same OS, but different licensing. – Chris S May 20 '10 at 19:02
  • 2
    It's an OEM disk, but I think the new standard for Win is to share libraries across versions, therefore the install disks have all versions on them, but you're limited by license as to which you can use. – stormdrain May 20 '10 at 19:13
  • all windows installs contain the same wim file. EI.cfg contins the versions available for install. When ei.cfg does not exist, Windows 7 setup process will display a screen during Install Windows wizard to ask user to select the operating system (edition) to install. – Jim B May 20 '10 at 20:32

Your source CD should be a volume license copy CD. If you look at the OEM cd you should see CLG files for all of the versions. If all you have is OEM media make a copy of the sources directory and delete all of the clg files except for the one you want and try the process again. The step-by-step guide assumes you are using media specific to the edition you are trying to install.

| improve this answer | |
  • All I have is the OEM disks. I tried doing as you said and copied the sources directory to a local drive, deleted all .clg files except Professional, opened that .clg in AIK, created new answer file, and went through all the steps. I saved it to the USB key (after deleting the old on on there), and tried the install again. It is still prompting me to choose which version, though. Is it because I'm using an OEM disk for the install? Thanks. – stormdrain May 21 '10 at 14:41
  • that's interesting. I have some OEM disks as well I'll have to try to reproduce your issue. When I initially took a look at my OEM disks (HP) the only real difference that jumped out was the catalog files, however the actual wim file must also be different from OEMs – Jim B May 21 '10 at 15:05

Got the answer to this question in another forum:


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.