1

We currently have memcached running on CentOS.

None of our PHP applications can connect, have tried multiple applications trying to establish access.

The most informative PHP error we get is:

"Memcache::get() [function.Memcache-get]: Server 127.0.0.1 (tcp 11211) failed with: Permission denied (13) in /var/www/.."

memcached 1.4.5

PECL 2.25

We can telnet and it works.

IP tables is full access from lo to lo.

We've tried this on two different servers with both compiled version and the rpm in CentOS 5.5 and get the same result.

Is there anything fairly obvious that we are missing?

3

is selinux on?

getenforce

You can disable it for testing via

setenforce 0
  • Yes, thank you. That turned out to be what it was. – DMClark May 26 '10 at 10:57
  • This is a horrible answer. See this answer (stackoverflow.com/a/29851476/650206) for a proper way to fix this without sacrificing security. Although for this, the command would be: setsebool -P httpd_can_network_memcache 1 – Jeremy Aug 2 '17 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.