I want to install Oracle 11g for 64bit on a Ubuntu 10.04 64bit server.Does anybody knows how to install the Oracle 11g on Ubuntu from the scratch(pre-installation to post-installation)?


Is this for development or personal use or for production? I'd review the release notes for Oracle to see if Ubuntu is supported, but further, I'd ask yourself why you want Oracle on Ubuntu. Nothing against Ubuntu but Oracle is a finicky beast an it is best not to stray too far from the supported platforms especially if this is a production setup. You may be better off biting the bullet and installing on RHEL or CentOS (not Fedora Core) because RHEL is supported and CentOS is known to work, being derived from RHEL sources. Again, while Ubuntu LTS may work nicely for 90% of your infrastructure, Oracle is very demanding - deviate from supported configurations at your peril.

Oracle's dependency checks are not for show. People run Oracle for two reasons - either they need the reliability and features of Oracle, or they're running it because someone else told them to (vendor, administrator, client, etc.) If you don't need it, don't use it because it's a severe pain for a neophyte to manage. If you do need it, you obviously have deep pockets - don't waste your time trying to get Oracle running on a desktop OS. Pay for RHEL or if you know what you're doing or don't care, use CentOS because it's as close a production OS for Oracle as you'll get without buying RHEL. I like Ubuntu too, but it's the wrong platform in this case.

  • we have to use ArrayTrack on our server and ArrayTrack will only work on Oracle. – Charly Jun 19 '09 at 8:19
  • 1
    +1 for the dev vs. production use. Oracle does not support Ubuntu at all, last I checked. They support RedHat, Oracle Enterprise Linux (which is re-branded RedHat), and maybe Suse. Anything else you're taking matters in to your own hands, and may not get support. Unless there is a compelling reason to use Ubuntu, I would switch to RedHat (or CentOS, which is derived from RedHat, but without the RedHat costs). – Milner Jun 19 '09 at 13:04
  • I assume you're talking about the free Express Edition (XE), it's fairly easy from our experience on a redhat system. If you've got the ability to switch, just go with a redhat-type system; oracle isn't worth stressing over. A colleague of mine installed the Enterprise Edition for a customer a little while ago. Maybe this is abnormal, but the customer uploaded the installer for us, which turned out to be a 700MiB CPIO archive... – Barney Desmond Jul 17 '09 at 7:20
  • Yeah, Oracle still ships some stuff as cpio archives. It takes me 5 minutes to sort out the options to unpack the damn thing; I'm not old enough to remember the pre-tar era... – arclight Aug 20 '09 at 2:00

I have both Oracle 10g release 2 and 11g running on my laptop Ubuntu 8.04 64-bit. I have following the phytian guide... What is the exact error you get during install?

BTW - some have suggested you install in a supported environment. If you want - create a new VM and install Oracle EL - a clone of RHEL, fully supported, fully free. I would just get the EL 5.3 from here.

BTW - if you use VirtualBox - the version in the Ubuntu 8.04 repository used to be old and didn't support 64-bit guests, so if you use VirtualBox and not VmWare, get the latest release from their site

----- EDIT -----

OK, I found my notes of the steps I took. I believe it is quite accurate.

Oracle Documentation talks about user "oracle" with groups "dba","oinstall". Since this is just a laptop, I used the default user/group (in my case, ofir/ofir), so change it to your user.


as root run:

ln -s /usr/bin/basename /bin/basename

ln -s /usr/bin/awk /bin/awk

ln -s /usr/bin/rpm /bin/rpm

mkdir /etc/rc.d

ln -s /etc/rc0.d /etc/rc.d/rc0.d

ln -s /etc/rc2.d /etc/rc.d/rc2.d

ln -s /etc/rc3.d /etc/rc.d/rc3.d

ln -s /etc/rc4.d /etc/rc.d/rc4.d

ln -s /etc/rc5.d /etc/rc.d/rc5.d

ln -s /etc/rc6.d /etc/rc.d/rc6.d

ln -s /etc/init.d /etc/rc.d/init.d

add to /etc/sysctl.conf :

fs.file-max = 65535

kernel.shmall = 2097152

kernel.shmmax = 2147483648

kernel.shmmni = 4096

kernel.sem = 250 32000 100 128

net.ipv4.ip_local_port_range = 1024 65000

net.core.rmem_default = 1048576

net.core.rmem_max = 1048576

net.core.wmem_default = 262144

net.core.wmem_max = 262144

add to /etc/security/limits.conf (replace ofir with your username):

ofir soft nproc 2047

ofir hard nproc 16383

ofir soft nofile 1023

ofir hard nofile 65535

Add to /etc/pam.d/login :

session required /lib/security/pam_limits.so

session required pam_limits.so

sudo apt-get install gcc make rpm libmotif3 libstdc++5 gawk alien ksh gcc-3.3 g++-3.3 libstdc++5 libc6 libc6-dev gcc make binutils lesstif2 ++-multilib


(I assume you have done it before, if not - just follow the GUI and cosult the docs):

run the installer, choose software only install. Ignore a few minor link errors (there were no link errors after patch)

If needed, install the examples disk as well

Install the (available from metalink)

run netca to create a new listener (accept all the defaults)

run dbca to create a new database (even the database console works great for me)


As a note... last time I installed Oracle, it depended on some binary packages that were 32bit, so I had to install the ia32-libs package ( aptitude install ia32-libs ) , for it to work...

Do you have any concrete problem?


Maybe you can take look here: www.pythian.com/news/968/installing-oracle-11g-on-ubuntu-804-lts-hardy-heron or www.pythian.com/news/1355/installing-oracle-11gr1-on-ubuntu-810-intrepid-ibex

  • I have tried that tutorial but not succeeded – Charly May 29 '09 at 12:08
  • What didn't work with it? Specific errors? Never tried it myself though, I'm more a RHEL/CentOS fan for Oracle. – Dvanes May 29 '09 at 12:18
  • oracle 11g 's Product specfic prerequisite checks get failed with lots of error. – Charly May 29 '09 at 14:25
  • I did just the samewauy mentioned in the page ->pythian.com/news/968/… – Charly May 29 '09 at 14:26

There are quite a few oracle-on-linux HOWTO documents on the web. Do a google search for some keywords in this space - there's quite a good chance you will come up with relevant documents.


I spent about a week last fall pulling my hair out trying to get Oracle 10g installed on Ubuntu. I finally gave up and switched to RedHat and had it up and running in one day.

  • ok, what the reason that you switched to red Hat? – Charly Jun 3 '09 at 9:40
  • @Charly - It's supported on the platform? – duffbeer703 Jun 19 '09 at 22:37

I installed Oracle 10 on Debian, and it sometimes failed on "make"'ing some files. Basically, I simply had to read the log, do the "make" by hand with the needed changes (usually some mangled path) then click "ignore" in the installer. Hope this helps.


I like the response given by arclight answered Jun 1 '09 at 6:48

I have been trying to get oracle to work on various linux distros not supported but all have issues. I will try RHEL or Centos for optimum performance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.