A year ago we bought several HP Compaq's laptops. Different models, from 6715s, 6715b, 6710s, 6735 ... (not all of them have gone through my hands so I don't know every one of them). They came with preinstalled Win XP Home, which worked fine (except that we deleted them and installed XP Pro cause we had that on older machines, and to get rid of all the promotional crap which came bundled with the OS).

Now, for some different reasons, some of the crew decides to put linux debian / opensuse up on them. And lucky me, since I'm working weekends, I'm the one who has to do it ;-(

Most of the things work fine except - on the first two models, I can't get wireless to work. They both, I think, have Broadcom BCM43XX internal cards, with which I have two problems:
- 1st - each of those laptops has a wireless turn on/off button, which upon startup doesn't go on, and therefore when opensuse boots, it's off - and cannot be turned on
- 2nd - I can't find the drivers for that card. I've even tried ndiswrapper, but haven't been able to get it to work

Has anyone managed to get the aforementioned working ?

6 Answers 6


The reason you're not seeing the light turn on is because the right driver isn't loading. The hardware expects a signal from the driver telling it to come out of sleep mode; it does this on Windows boots too, if you watch it.

You're looking for the b43 driver. Don't use the bcm43xx driver unless you absolutely have to because it's legacy now. The latest versions of the drivers are usually packaged up in new vanilla kernel releases, but you can get more information at:


The wireless card link at the openSUSE WIKI looks a little old, but you could always ask at http://forums.opensuse.org or browse their Wireless Networking section. They've got quite a few openSUSE + Wireless experts over there.

  • Do you own a card mentioned in the question?
    – cstamas
    Jun 1, 2009 at 21:08
  • @andrewd18 - Sorry for a little late reply. I also tried drivers from the abovementioned site; unfortunatelly, the little light stayed dead :-( I think it has nothing to do with the drivers directly, since I can use it on windows to turn off the card, before I even install drivers for the card.
    – Rook
    Jun 1, 2009 at 22:03
  • @cstamas - I do not own one of the HP laptops in question, however I do have a Compaq laptop with a Broadcom 43xx chipset. @Idigas - Can you post the output of "lspci -v" and "lspci -n"?
    – andrewd18
    Jun 2, 2009 at 17:35

My sister has HP 6730s it came with card you mentioned. I played a bit with it, but it is a crap and did not work. I found some driver at broadcom's site, I was able to associate with WPA-EAP method, but after a few second the machine frooze for about 30sec. The it came back with a disconnected AP.

Get a decent card like Intel's 5000n (4965AGN) card, it will work out-of-the box. (Beware the Bios blacklists some "unauthorized" cards, 4965AGN seems to be fine.)

  • Unfortunatelly, we can't change stuff like we would like. We have a deal with local HP, for getting new hardware, repairs in contracted time and so ... bad side is, they don't mention linux in that deal and don't offer support for it. So I'm stuck. Can't change, can't ask for help (Well ... I can, but they won't answer :-(
    – Rook
    Jun 1, 2009 at 22:05

I have worked with an HP laptop running Ubuntu where the wireless would not work because of a conflict with the bluetooth drivers. I had to write a script that would first disable bluetooth and then setup the wireless card. I do not have access to this machine to look at what I did, so I can't give any more specifics than that.

It would be helpful if we could see the output (in regard to the card in question) of "lspci -v".


Depending on what card you have, you may get lucky using the b43 driver. Most likely though, you need to use either the wl driver (available from broadcom if your distribution doesn't cover it) or ndiswrapper (with drivers from Windows XP).

No matter which driver you're using, you may run into conflics with ssb (which will be loaded with ohci_hcd). If you make sure to load b43/wl/ndiswrapper before ssb, you should be fine.

Also note that the on/off button may become after this. I've assisted someone who spent almost a full day trying to debug what had broken his wireless, only to discover the button had somehow been set to off.


`ndiswrapper' should work. Type ndiswrapper -l and it should show something like

netrt61g : driver installed
device (1814:0302) present (alternate driver: rt61pci)

If you do not see device present then it is not the correct driver. Remove all the current installed drivers using ndiswrapper and try new one. Keep only one driver installed at a time. Once you see device present then you have to do

ndiswrapper -m
ndiswrapper -mi
ndiswrapper -ma

If you see the alternate driver message like I have copied above then edit file /etc/modprobe.d/blacklist and add following line at bottom

blacklist rt61pci

Replace rt61pci with whatever name you get in alternate driver message.

After this reboot the machine and see if card got detected. If not add following line to /etc/rc.d/rc.local modprobe ndiswrapper

and reboot once again.

Try to use NetworkManager for wireless connections. It causes too many problems with wired connections but for wireless NetworkManager is awesome.

I have used above methods of little adjustment here or there a lot of times and installed Windows driver on variety of Linuxes on hardware of many vendors including HP, Dell, Acer, IBM. `ndiswrapper' has never disappointed me. In fact in older versions of Linux even if drivers work out of the box, the performance of ndiswrapper based drivers is way way better then default Linux drivers. So it might be benefitial to use ndiswrapper even if the card gets detected by default.

If OS is not an issue. Try installing Fedora 11. It has amazing supports for wireless cards and even performance of default drivers is at par with ndiswrapper based drivers.


I inherited my wife's Dell Inspiron that had such a card in it. I did manage to beat ndiswrapper into submission enough to get it to work okay, but it would fail on un-suspend more often than not, so I bit the bullet and paid $30 to replace it with a well-supported intel wifi card. Not elegant, and someday hopefuly not necessary, but if it has to work well, now, then certainly possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.