I am trying to install Windows Web Server 2008 x64 (have tried 32-bit, too) onto an IBM eServer 326m and am getting the following error message some time after the unpacking files section:

Windows could not update the computer's boot configuration. Installation cannot proceed.

I can repair the boot information using the Repair option in the WinPE bit of the setup, and it reboots into the Windows installation, so it has good boot data on the drive.

Just to complicate things, the server does not have a DVD-ROM so I'm installing from HDD to HDD, both SATA, one an SSD. I've tried each drive in isolation, e.g. removing the SSD and installing from spindle onto itself, same error every time.

Flashed IBM BIOS, too.

Thanks for your help.



Windows setup, when run right from booting the WinPE bit gives:

Required cd/dvd drive device driver is missing.

And will not continue. I thought this was a quirk of running setup from the disk so I've previously exited and gone into the command shell and ran setup from the \Sources folder on the media (copied to the HDD) and not the \Sources in the RAM disk.

This works, but gives the original problem above. I'm thinking that the two issues are related. Two different articles on Technet point to the UpperFilter registry entry but for both errors.

There's clearly a driver missing. Even though setup can see and use my drives, it doesn't like something. Being an IBM server, the software for it is typical IBM garbage.

I can't understand how putting a PC in a long thin case makes them suddenly need 100 BIOS updates and 50 bespoke drivers. No wonder Google use desktop PCs as servers.


Windows 2003 Server (64) has gone on fine with just the single SSD online. When I connect the other SATA drive (stock IBM part), the POST boot just halts at the point where it should hand off to the boot sectors; just a flashing cursor, top left.

My current focus is now on SATA drivers for the the machine - says its a ServerWorks, Broadcom controller but cannot find a driver anywhere.


I finally figured out the right Update Xpress CD to run (4.05 CD1) in Windows and boot from DOS (I chose to upgrade the ISMP (whatever that is), which defaulted to 'don't update' for some reason), and now I can attach the other HDD. Hope this good behaviour sticks.

Even though the LSI Logic SCSI adapter was disabled the last time I looked, it does show in Windows and now with the right driver, I think. No more yellow ! bad devices.

Painful work but I Will try upgrading to 2008 Server soon.


If you have ILO or similar, you should be able to attach a CD/DVD ROM remotely (works great btw)

What OS was on the drive?

This page: http://support.microsoft.com/kb/931697/en-us

Suggests formatting will help, else, there is a registry change that may help. (for vista, but they haven't changed much)

| improve this answer | |
  • Hi Grizly and thanks for your answer. Added updates to my question. – Luke Puplett May 27 '10 at 9:08

Okay, Windows Web Server 2008 x64 is up and running. I installed from that Windows 2003 build, i.e. ran setup.exe from Windows, and it installed fresh, not an upgrade, because it was Web edition (and 2003 was Standard).

I supplied the LSI Logic driver from the IBM site at the first opportunity (before first restart, while still in 2003), as mentioned on this site or the one that links to it.

I'm knackered.

  • Update BIOS using Flash USB stick (.img file on IBM site).
  • Install Windows 2003 x64 from CD.
  • Download Update Xpress 4.05 CD1.
  • Stick CD in and poke the Autoplay, apply updates. Ignore 1992 style IBM software.
  • Eject CD and reboot to check Windows boots.
  • Stick CD in a restart, boot from CD and apply all updates, including ISM.
  • Eject CD and reboot.
  • Copy Windows 2008 media to second drive (that's what I did).
  • Unpack LSI Logic driver .exe to folder.
  • Run Setup.exe from within Windows and remember to add the driver above.
  • Get in the bath and watch something nice on laptop.
  • Empty bath and return to Windows 2008 "change password" screen.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.