I can no longer log into Oracle Enterprise Manager 11g. I get this error message:

ORA-28001: the password has expired (DBD ERROR: OCISessionBegin)

I could log into the server using SQLPlus. I warned me that the password was going to expire in 7 days (which is not the same as being already expired). Following advice from several documents, I ran these commands from SQLPlus:

ALTER USER sys IDENTIFIED BY new_password;
ALTER USER system IDENTIFIED BY new_password;

SQL*Plus no longer warns about passwords, but I still cannot use the Enterprise Manager. Then I followed this to remove password expiration:

LIMIT password_life_time UNLIMITED

And I've also restarted the Oracle services. In case it was using cached credentials, I've tried to connect from several browsers in several computers.

No way: I still get ORA-28001 in Enterprise Manager. What am I missing?

Update: Some more info

SQL> select username,ACCOUNT_STATUS,EXPIRY_DATE from dba_users;

USERNAME                       ACCOUNT_STATUS                   EXPIRY_D
------------------------------ -------------------------------- --------
MGMT_VIEW                      OPEN
SYS                            OPEN
SYSTEM                         OPEN
DBSNMP                         EXPIRED                          24/05/10
SYSMAN                         EXPIRED                          24/05/10
OUTLN                          EXPIRED & LOCKED                 16/11/09
FLOWS_FILES                    EXPIRED & LOCKED                 16/11/09

USERNAME                       ACCOUNT_STATUS                   EXPIRY_D
------------------------------ -------------------------------- --------
MDSYS                          EXPIRED & LOCKED                 16/11/09
ORDSYS                         EXPIRED & LOCKED                 16/11/09
EXFSYS                         EXPIRED & LOCKED                 16/11/09
WMSYS                          EXPIRED & LOCKED                 16/11/09
WKSYS                          EXPIRED & LOCKED                 16/11/09
WK_TEST                        EXPIRED & LOCKED                 16/11/09
CTXSYS                         EXPIRED & LOCKED                 16/11/09
ANONYMOUS                      EXPIRED & LOCKED                 16/11/09
XDB                            EXPIRED & LOCKED                 16/11/09
WKPROXY                        EXPIRED & LOCKED                 16/11/09
ORDPLUGINS                     EXPIRED & LOCKED                 16/11/09

USERNAME                       ACCOUNT_STATUS                   EXPIRY_D
------------------------------ -------------------------------- --------
FLOWS_030000                   EXPIRED & LOCKED                 16/11/09
OWBSYS                         EXPIRED & LOCKED                 16/11/09
SI_INFORMTN_SCHEMA             EXPIRED & LOCKED                 16/11/09
OLAPSYS                        EXPIRED & LOCKED                 16/11/09
SCOTT                          EXPIRED & LOCKED                 16/11/09
ORACLE_OCM                     EXPIRED & LOCKED                 16/11/09
TSMSYS                         EXPIRED & LOCKED                 16/11/09
XS$NULL                        EXPIRED & LOCKED                 16/11/09
BI                             EXPIRED & LOCKED                 16/11/09
PM                             EXPIRED & LOCKED                 16/11/09
MDDATA                         EXPIRED & LOCKED                 16/11/09

USERNAME                       ACCOUNT_STATUS                   EXPIRY_D
------------------------------ -------------------------------- --------
IX                             EXPIRED & LOCKED                 16/11/09
SH                             EXPIRED & LOCKED                 16/11/09
DIP                            EXPIRED & LOCKED
OE                             EXPIRED & LOCKED                 16/11/09
APEX_PUBLIC_USER               EXPIRED & LOCKED                 16/11/09
HR                             EXPIRED & LOCKED                 16/11/09
SPATIAL_CSW_ADMIN_USR          EXPIRED & LOCKED                 16/11/09
SPATIAL_WFS_ADMIN_USR          EXPIRED & LOCKED                 16/11/09

4 Answers 4


shameless self promotion What to do when Enterprise Manager is not able to connect to the database instance (ORA-28001)

  • 1
    Can you please, write the solution to your answer rather than just provide the link ? may be some time the link will not active. Jun 15, 2016 at 5:43

Look at your SYSMAN and DBSNMP users. AFAIK EM uses them.

  • How can I change their password? I've never set any to begin with. Is it the same as SYSTEM? May 27, 2010 at 9:14
DBSNMP                         EXPIRED                          24/05/10
SYSMAN                         EXPIRED 

Please Change these two users passwords and then try again.

  • 1
    Please note there's another (older) answer that's exact to yours, together with an unanswered request for clarification. Sep 22, 2012 at 19:56

What to do when Enterprise Manager is not able to connect to the database instance (ORA-28001) 32 Replies

If you are trying to connect to the Oracle enterprise Manger and you get the following errors:

Enterprise Manager is not able to connect to the database instance.

And in the “Agent connection to instance” section:

Status: Failed Details: ORA-28001: the password has expired (DBD ERROR: OCISessionBegin)

One of the reasons could be that the password for the SYSMAN user is expired. However, changing the password alone will not solve this issue. Several additional steps are required in order to make Oracle Enterprise Manager connect:

Before you start: Verify that ORACLE_HOME, ORACLE_SID environment variables are set. – If not, set them using as environment variables or open a command line and type SET ORACLE_SID=

  1. Stop the dbconsole: emctl stop dbconsole (dos and Unix) or using the windows services stop the OrcleDBConsole.

  2. Connect to the database as a user with DBA privilege with SQL*Plus and run the following command:

alter user sysman identified by ;

  1. Verify that the new password works SQL> connect sysman/

  2. Go to ORACLE_HOME//sysman/config and save a backup of the emoms.properties file.

a) Open the file emoms.properties and search for: oracle.sysman.eml.mntr.emdRepPwd=

Replace the encrypted value with the new password value

b) Search for oracle.sysman.eml.mntr.emdRepPwdEncrypted=TRUE and change TRUE to FALSE

c) Save and close emoms.properties

  1. Restart the dbconsole:

emctl start dbconsole (dos and Unix) or using the windows services start the OrcleDBConsole.

  1. Open emoms.properties again and Search for: a)oracle.sysman.eml.mntr.emdRepPwd= verify that the password is encrypted

b) oracle.sysman.eml.mntr.emdRepPwdEncrypted= verify that the value is set to TRUE

  1. Refresh Oracle Enterprise Manager
  • 1
    Thanks for copying in the answer from the link of the accepted answer! But it would be nice if you'd give it an attribution, making it clear who actually wrote it.
    – Jenny D
    Jul 31, 2019 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.