2

During copying files via lan my Ubuntu Server 10.04 hung up and I had to reset the computer.

After reboot, I got: Grub error 17, so I tried the rescue alternate CD, but I got a info, that no partitions were found on the disk.

I used testdisk to restore the partitions. Using fdisk -l shows the partitions now, but when the system boots up I does nothing but displays:

L234:

When I plug the drive to another computer, it is not automatically mounted and I can't access the data.

What to do now?
How to restore the grub and boot up the system?

1

You can try to use a regular (Desktop) Ubuntu CD to boot the computer and see if you can mount the partitions. You mainly need to verify the disk (if it's /dev/hda, for example) so that you know how to restore grub. This is a great page for information on the rest of the process to re-install grub and the MBR to let you boot it again. However, if your problem is that you can't mount the partitions at all, then fixing the boot record won't solve the problem. If this is the case, can you post back what you see from "dmesg | tail" immediately after trying to mount the partition?

  • Thanks for the answer. Already tried these methods. The problem is that the partitions are visible now, but I keep getting "unknown file system" like errors (even when I try to mount). – takeshin Jun 4 '10 at 14:44
  • What is the output of "dmesg | tail"? It sounds like the file systems might be gone, but the error details might help. – Paul Kroon Jun 7 '10 at 21:28
1

You can run Ubuntu on single user mode and then you do grub install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.