Hello friends...

In My computer

Lan card model is Realtek RTL8168B/8111B PCI-E GIGABIT ETHERNET NIC (NDIS 6.20)

My system is dual boot windows 7 and redhat 5.1.Redhat is not picking up this model of Lan card automaticlly.

I tried it by downloading from realtak site for this particular model and find some .tar packages for my kernal and when i tried to install them ...

check old drivers & unload it

build the module and install

make ***/lib/modules/2.6.18-53.e15/build: no such file or directory stop

make[1]: ***[modules] error 2

make : [modules] error 2

i downloaded tar files from sites and unpack according to their instrution i tried to run autorun.sh script as mentioned in readme file but after doing this it is showing above error...

Now what to do i am not getting

  • I assume you picked up the RealTek LINUX driver for kernel 2.6.x and 2.4.x.
  • Then, you followed the README in that tar-ball on your RedHat 5.1.
    • however, it stalled with the Errors you list,
    • Were you running the autorun.sh script as root on RedHat?
  • From your error lines, it seems Make could not enter the lib directory 2.6.18-53.e15
    • Can you check how much of that path is valid on your RedHat system?

ps: I think this will be better answered at Superuser; but, don't make a second posting there, this might get moved.


  • Use whoami or id to check if you are logged in as root or with your username
    • if you are not logged in as root, you can do a root login from another terminal
      or just su - root from that terminal; you will need to know the root password
  • You can check if the error path is available on your system with a,
    ls /lib/modules/2.6.18-53.e15/ etc
    • There will also be a log.txt file generated from your last compile attempt,
      this would have the autorun.sh outputs recorded for debug
      (so, you don't have to re-run the script to see them).
  • 2.6.18-53.e15 is the kernel,
    Look at this LinuxQuestions thread on Installing NIC drivers.
    You seem to be missing the kernel sources for the driver compile to work.
    that thread is discussing a similar problem with the r8169 driver installation.
  • yaa u are right i picked up for 2.6 ..I dont know how to enter these all things so will u plz explain things little bit actully i am not able to use internet their or do my practical plz help me – Deepak Narwal May 30 '10 at 4:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy