I've tried installing Exchange 2010 on Windows Server 2008 R2 (only domain controller and all-in-one system).

I did setup.exe /prepareAD, setup /prepareSchema and it worked fine the first time I did it.

Unfortunately due to problem with Hub Transport installation related to (at least from what I've read) IPv6 being disabled (some say disabling it helped them while some enabling helped them). I did it the proper way by using registry entry to disable IPv6 but it still errored out. So i managed to uninstall everything (renamed some old entries in registry of failed Hub Transport roles and tried to reinstal Exchange after rebooting server.

Unfortunetly running setup /prepareAD now gives an error:

D:>setup /PrepareAd

Welcome to Microsoft Exchange Server 2010 Unattended Setup

By continuing the installation process, you agree to the license terms of Microsoft Exchange Server 2010. If you don't accept these license terms, please cancel the installation. To review these license terms, please go to http://go.microsoft.com/fwlink/?LinkId=150127&clcid=0x409/

Press any key to cancel setup................ No key presses were detected. Setup will continue. Preparing Exchange Setup

Copying Setup Files              ......................... COMPLETED

No server roles will be installed

Performing Microsoft Exchange Server Prerequisite Check

Organization Checks              ......................... COMPLETED

Setup is going to prepare the organization for Exchange 2010 by using 'Setup /P repareAD'. No Exchange 2007 server roles have been detected in this topology. Af ter this operation, you will not be able to install any Exchange 2007 server rol es.

Configuring Microsoft Exchange Server Organization Preparation ......................... FAILED The following error was generated when "$error.Clear(); buildToBuildUpgrade -ExsetDataAtom -AtomName OrgLevelCt -DomainController $RoleDomainController" was run: "An error occurred with error code '2147504140' and message 'The data type can't be converted to or from a native Active Directory data type.'.".

The Exchange Server setup operation did not complete. Visit http://support.micro soft.com and enter the Error ID to find more information.

Exchange Server setup encountered an error.

Unfortunetly if i rerun the setup it complains that it needs setup /prepareAD to be run first.

Basically all that works now is setup /PrepareSchema and setup /PrepareDomain complains that prepareAD wasn't done.

For full information I'm also attaching error I had before I've uninstalled everything and tried again:

Hub Transport Role Failed

Error: The following error was generated when "$error.Clear(); install-ExsetdataAtom -AtomName SharedMachineSettings -DomainController $RoleDomainController" was run: "An error occurred with error code '2147950640' and message 'There is no such object on the server.'.".

An error occurred with error code '2147950640' and message 'There is no such object on the server.'.

2 Answers 2


I've managed to fix this by manually removing every trace of Exchange on this server (not all steps were found at my server but i post them anyway). And kids don't do this at home. This is not supported and may harm your system. I was desperate:

  1. Run setup /m:uninstall
  2. Stop and disable all the Exchange 2010 services
  3. Use Registry Editor (Start->Run->Regedit) to remove these Exchange related registry keys:
    * HKLM\SOFTWARE\Microsoft\Exchange
    * HKLM\SYSTEM\CurrentControlSet\Services\MSExchange* (all the keys starting with “MSExchange”)
    * HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft Exchange
  4. Remove the entire Web Server role (don’t forget to reinstall afterwards as it’s a prerequisite for E2K10!)
  5. Remove the Exchange 2010 server from Active Directory. I ended up deleting the entire “Microsoft Exchange” branch from ADSIEdit (Configuration Container > Services > Microsoft Exchange) as my Org only counts one server.
  6. Use Windows Explorer to delete:
    * C:\Program Files\Microsoft\Exchange Server
    * C:\ExchangeSetupLogs
  7. Use Windows Installer CleanUp Utility to remove all the exchange related info from the installer database.
  8. Remove the security groups created by Exchange setup from AD
  9. Use CC Cleaner to remove registry entries for Exchange

I also found this link which gives a bit bigger overview: http://msexchangehelp.wordpress.com/2010/02/10/manually-uninstall-last-exchange-2010-server-from-organization/

Anyways it solved the problem that installation went thru but again I am at square one with corrupted installation since Hub Transport failed to install AGAIN. So redoing this steps again... and trying installation again with IPV6 disabled.

  • Yes, yours is an issue installing a role after the base product installs. Mine is more a general workaround for reinstalling the base product if it can't be done thru the main setup wizard after a failed install. I wish ya luck man, and will look forward to hearing of a solution!
    – user62332
    Dec 2, 2010 at 15:29

I had a similar problem due to a defective DVD. The AD preps ran fine, and Exchange files were copied successfully, but it hung indefinitely trying to read the disc during Language Pack installation. I had no choice but to kill the process thru Task Manager. I replaced the DVD but SETUP.EXE would fail very soon into the process with "Exchange Server setup encountered an error."

Since the base product (sans roles) never completed, I tried just deleting the two folders mentioned in the first answer:

  • C:\Program Files\Microsoft\Exchange Server
  • C:\ExchangeSetupLogs

then running CCleaner to remove any Registry entries. I continued to get the error in SETUP.EXE.

On a whim I decided to try running EXCHANGESERVER.msi from the root of the DVD, and it WORKED -- very quickly, too. The base product was installed, and from there I could run SETUP.EXE or simply modify the existing install from the Control Panel to add roles and complete my installation.

  • In my case it was all .ISO format so wasn't faulty DVD. But thanks for sharing. Maybe someone else will have a go at it some day ;)
    – MadBoy
    Nov 20, 2010 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.