I have a Windows 7 (32 bit) client where the print spooler service keeps stopping a few seconds after I restart it.

The event log doesn't provide any clear indication of the cause of the error. It only provides the following information:

The Print Spooler service terminated unexpectedly. It has done this x time(s).

I cannot find any information on this. I tried uninstalling whatever print driver was there. However this did not fix the issue.

  • How did you uninstall the printer drivers? Did you uninstall them from Programs and Features, from the drivers own uninstaller, or from the print server properties in Devices and Printers?
    – joeqwerty
    Jun 1 '10 at 22:54

+1 for bad driver

Better way to delete drivers:

Under Control Panel and Administrative tools theres a new option here in windows 7 labled Print Management. From here you can see all the printers you have ever installed and all the drivers that are still amongst the system. under the option All Drivers on the left is where I found the print driver I new was hanging around somewhere but couldnt find to remove, Right clicking on the printer name and choosing Remove Printer Package allowed for windows 7 to scan for and find the drivers and allows you to delete them. (Similar to the Server properties Drivers Tab from previous windows versions)


I've had this problem a lot on both Windows 7 (64 bit) and Windows XP.

There is only one solution that has worked for me, and it's not going to Services and starting the Print Spooler, because the Print Spooler will just stop again within seconds or minutes.

What has worked for me in both Windows 7 (64 bit) and Windows XP, is to delete the contents of the following folders:




Once I do this, I do not have to reinstall any of the printers. I just physically disconnect my local printer (unplugged the USB cable), wait a few seconds, and then reconnect it.

  • For me, deleting all that's in C:\Windows\System32\spool\PRINTERS did the trick. Didn't have to do the rest. Guess sometimes it's just a messy file in the printer pool.
    – Asaf R
    Mar 5 '11 at 21:38
  • This solution helped me bring back the printers. I had to remove the drivers in the drivers folder.
    – Rowell
    Feb 15 '12 at 20:56

OK, I fought with this issue for 6 weeks. I updated all the drivers on my printers, turned on network discovery. The fix that fixed it for me on my 32 bit Win7 professional. First,

Start>Run type in services. scroll down to Print Spooler> Stop the service.

Next. start>run>c:\windows\system32\print.exe. Right click on the file. Change ownership of the file from Trusted Installer to Adminstrators. Once Administrator has ownership, change permissions for all listed user to Full Control. Apply and OK.

Start the Print Spooler.

25 machines later, 25 confirmed fixed.


My guess is that this is a bad driver. You might download Process Monitor and attempt to find out which files are accessed when you start the print spooler. My guess is that you have a bad print driver or print monitor.

This isn't an elegant solution, but if you have a bad driver, you may have to manually clear the subdirectories under C:\Windows\System32\spool\drivers to prevent the drivers from loading. Also make sure you don't have any print monitors (monitoring consumer-level printers), PDF printers, FAX printers, etc. running.


change ownership to admin and give full access to "c:\windows\system32\spoolsv.exe". Restart your computer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.