When I connect to my machine and I am on the local network Remote desktop does not require my password. However, when I try to remote into my machine remotely over the Internet, it makes me enter my password each time. Is there a way to have it remember my password, and not prompt me each time?

2 Answers 2


Password is stored per-address in the RDP settings. Most likely your machine has a different address on the local network and on the internet due to a NAT in between.

What you need to do is to connect your client to the internet. Start up Remote Desktop Connection. Enter the address. Choose Options, then check "Allow me to save Credentials". Then log in as usual and chose to save the credentials.

Note that your password will be saved in clear text on the local system, so don't ever do this on a system that is not fully under your control. There are also a bunch of other security issues with RDP, which is why you should not, if possible, expose it to the internet.

If you really need RDP from the internet a VPN to protect the connection is highly recommended.

  • 1
    It still asks me for my password. even with that checkbox checked. It has a message "login attempt failed" and then prompts me, but I know that my password was correct.
    – BrokeMyLeg
    Commented Jun 2, 2010 at 23:22
  • If you get the "login attempt failed" before you log in the username/password that RDP has stored is wrong...
    – pehrs
    Commented Jun 3, 2010 at 6:39
  • If you're talking about going from a work to home environment, then you may need to specify the domain that your account is in. As by default your home computer will specify the localhost as the domain.
    – Tatas
    Commented Oct 7, 2010 at 21:17

Try eliminating any stored passwords for that user and then create a new connection, store that users password once again, an then instead of connection trough a example.rdp file connect trough a shortcut that leads to your server, shortcut leads to: mstsc /V:server

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .