0

I've submitted my web site to different apps like YahooWebmasters and similar places. They see my web site's main page's title as Index of/ . However I see it normally, as My Title.

Server: it says Apashi (wtf!?), it is Apache in reality
PHP 5.2.5
FreeBSD
cPanel Version 11.24.4-RELEASE
Kernel version 6.3-PRERELEASE

main page: index.html
I guess it is because of index.html
But why?

3
10

your server has been rooted and your apache is compromised.

apashi on freebsd is a signature that appears to take traffic that comes in from search engines to legitimate sites, and redirects it. Surfing the site with a non-google/non-bing url results in normal operation. It is possible someone is using the same webserver signature for legitimate purposes, but, based on the behavior above, it seems likely that it is a hacked version of apache.

6
  • yikes! Are you deducing that from "Apashi" or do you have the inside track on this one?
    – Chris_K
    Jun 3 '10 at 2:55
  • 5
    apashi on freebsd is a signature that appears to take traffic that comes in from search engines to legitimate sites, and redirects it. Surfing the site with a non-google/non-bing url results in normal operation. It is possible someone is using the same webserver signature for legitimate purposes, but, based on the behavior above, it seems likely that it is a hacked version of apache. Jun 3 '10 at 3:02
  • It is very tempting to mark your comment as great instead of upvoting your answer. You should consider pasting your comment into the answer.
    – chronos
    Jun 3 '10 at 12:43
  • @user6738237482 : That's interesting. Do you have a link which explains that "apashi" on FreeBSD is a legitimate signature? I just browsed my apache22 source files (although this is FreeBSD 7.2), and I don't see the string 'apashi' anywhere. Jun 4 '10 at 17:01
  • I've never seen it used legitimately. However, people do change servernames for whatever reason, and since one could assume that Apashi could be the drunk pronunciation of Apache, who knows. In any case, based on the behavior he's seeing, I think we can conclude that his server has been rooted and compromised and that he didn't recompile Apache with a different Signature just for the heck of it. Jun 4 '10 at 17:15
2

make sure "Apashi" is configured to use index.html as the default page. That'll prevent giving out directory listings.

1
  • The more secure method would be to disable directory listings entirely.
    – grufftech
    Jun 4 '10 at 18:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.