One of my users is experiencing a problem whereby the mouse scroll does not work on the Citrix published application. I have tried to install mouse drivers on his local PC as well as swapping the USB with a PS/2 mouse but still no go. I have researched this issue for a few days but have not been able to find a fix.

PC is running Windows XP and ICA client is version 10

I am pretty sure its a problem local to that PC since every other user using the application published on the same server are not having any issues. What could it be?

  • Does that mean that the mouse wheel works fine on that computer everywhere else? Also, what application is being published? – Paul Kroon Jun 3 '10 at 10:47
  • @Paul - Hi Paul, Yes that's correct. It works fine on that computer everywhere else. The application is a third party application that is used by about 10 other users and none of them have experienced this issue before. I escalated to the vendor and they came back saying that they have not seen it before as well. At this moment, I believe its local to that PC but I don't know what else to try... Mouse properties in Control Panel does show that the mouse has a wheel so its not like Windows is not detecting it at all – molecule Jun 3 '10 at 23:22
  • Do other users on that same PC have the same issue? How about regular users vs admin users on that PC? If possible, can you try just RDP to the server to run the app and see if the problem still exists? Sorry, I'd post an answer instead of comments, but I don't have an answer yet, just more questions :). – Paul Kroon Jun 4 '10 at 22:44
  • @Paul - to answer your question, Yes, other users on the same PC have that issue and that user is a local admin of the PC. RDP to the server and running the app does not result in the scrolling issue - meaning he can scroll when using RDP. Thanks again for your comments :) – molecule Jun 6 '10 at 23:26

I guess I might as well start an answer for this. Any chance you can post the Citrix ini files located at %userprofile%\application data\icaclient, particularly APPSRV.ini? Also, do you use an ICA file to make the connection? If you can't/would prefer not to post the files, try to compare all of them with a working computer. These files also exist in the Citrix folder under Program Files somewhere, which you can also compare. In case you haven't already tried it, you might want to attempt to reinstall Citrix on this client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.