I have a Windows Server 2008 (not R2) machine which has problems with redirected printing.

Clients connecting via Remote Desktop have their printers redirected and appearing for them to print to, but printing from applications on the server to local printers is giving blank pages, missing pages, or pages with headers/footers but no middle section. The issues are consistant for similar prints, but sometimes other prints and/or applications will work correctly.

I have installed PDFCreator locally on the server, and the same print jobs sent by the same application appear correctly in the PDFs. Printing that PDF via the redirected printer prints correctly.

I have tried the following:

  1. Installing drivers. I’ve installed several drivers different drivers, for both the client and server operating system and architecture, on the client and the server.
  2. Reinstalling the printers. I’ve tried reinstalling on remote print servers, the clients, and the host server, and tried different client machines.
  3. Granting everyone full permissions on the print spool folder on the server.
  4. Editing the registry to forward non-USB ports (http://support.microsoft.com/kb/302361)

None of these have made any difference.

The clients are using Windows 7 or Windows XP and none of them have any issues with printing locally.

Any ideas?


  • You say that "Printing that PDF via the redirected printer prints correctly.", which would imply to me that it is a specific application on the remote desktop which is having problems. Is this the case?
    – seanyboy
    Jun 9, 2010 at 15:14
  • Also, Is the printer driver used on the Remote Server the TS Easy Print driver?
    – seanyboy
    Jun 9, 2010 at 15:15
  • It was one specific application that was causing most problems but we had noticed it in other apps. Jun 15, 2010 at 9:54

1 Answer 1


Turned out to be a permissions issue. Connecting via remote desktop as the server administrator worked, so we started removing restrictions on local drives until it started working again for the standard users and we could work out where it was trying to write to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.