I'm trying to connect to a repository I've set up on our server from another host on the same network, but the connection is failing.

checkout command: svn checkout svn://

error: Can't connect to host '' : Connection refused

I tried probing port 3690 with telnet, and I can't seem to connect that way either. I thought the port might be blocked, so I added an entry for port 3690 in sysconfig/iptables, but it doesn't seem to have had any effect at all.

I'm sure svnserve is running, because I can checkout the repository on server using the same command above.

What can I possibly try next?


The next step I would recommend would be to run netstat -tapnl | grep 3690 to see if it is listening on that port. You will want to make sure it is not listening on only the loopback interface "". You want it to either be for all ips or an IP that is reachable from other machines on the lan.

You might also want to post your iptables.

  • [netstat -tapnl | grep 3690] [tcp 0 0 :::3690 :::* LISTEN 11859/svnserve] It's not Sorry, I'm a little new at this... I've been going through google looking for documentation on netsat -an output... I've found information on as a Local/Foreign address, but I'm not sure how to interpret the colons. – akaii Jun 4 '10 at 6:53

Have you tried telnetting from the box that svnserve is running on? As in telnet 3690 It looks like svnserve is listening based on the output you have there. If you are successful, and it is listening, than the problem lies between the client and server boxes. Can you ssh or ping from one to the other?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy