I have the latest vmware server isntalled on ubuntu 8.04 lts 64 bit. I access the user interface over this url, which matches my ip and port settings:

Sometimes it works in fierofox 3.6, but sometimes not. Same in Google Chrome.

When it does not work, what happens is that the cert is checked, the browser is loading something, but the result is a white page. Sometimes the favicon of vmware (blue with 3 squares) appears, but only the white page. And sometimes it works. I reload many times, most of the time the whit epage appears again. On some days I succeed. But on many days not.

I can give more info if someone tells me what is needed.

Please help, we need this badly.

Edit: Sometimes in a middle of an otherwise successful session this message appears in the browser:

The server could not complete a request (HTTP 0 ).

The server encountered an unexpected condition that prevented it from fulfilling the request. If this problem persists, please contact your system administrator.

Edit2: Solution from the accepted answer:

Go to the about:config page in firefox and search for the setting security.enable_ssl2

Set it to true and reload the vmware gui. Worked for me.

3 Answers 3


I was suffering exactly the same problem for a long time and neither these hints (CTRL-R or vmware-mgmt restart) worked for me. But some time ago i found a thread on the official vmware forum there people tracked down the problem to some SSL-protocol-wiredness between vmware-webui and current webbrowsers.

To cut things short, you must activate SSLv2 Mode on your webbrowser and maybe reload the webui via CTRL-R. You can get detailed instructions about this workaround on my Blog.


(its written in german but maybe the screenshots are helpful)

  • Stefan please answer the question within your answer rather than redirecting to your own site. Thank you.
    – Chopper3
    Jul 22, 2010 at 10:02
  • This is really amazing. I tried it and after changing the setting on the first relod it worked. After many months of suffering this is a relief.
    – user12096
    Jul 22, 2010 at 19:34

I don't mean to rain on your parade but VMware has announced end-of-life for the VMware Server 1x-2x products. A quick Google search of your issue will turn up tons of results that show VMware Server has had long standing issues with current linux distros. Alternatives include:ESXi free (best if your hardware is supported), VMware workstation(not free), and VMware Player(free).

If you are running a browser on the host system try using "localhost" in the url instead of an IP address - I had some improved luck with that method when I used to use VMware Server.

Good Luck!

  • thank you. i did not know it was 2.x end of life.
    – user12096
    Jun 8, 2010 at 19:24
  • using the machine name instead of the ip did not really help :/
    – user12096
    Jun 8, 2010 at 19:48
  • i have the impression now that running firefox from the machine where vmware serer is running (via ssh -X) using https: / / localhost works the best after trying everything out. Thank you very much for sharing
    – user12096
    Jun 12, 2010 at 23:55

add a /# after ui?


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .