0

I had a dns forwarder configured that seems to be choking on a particular server name so I switched to using google's dns as a forwarder (8.8.4.4). When I change that setting in Windows DNS (Server 2008 R2) Do i need to restart the dns service for the change to take effect?

I ask because i can do a nslookup on the name using 8.8.4.4 and it resolves but even with 8.8.4.4 in my forwarders list it will not resolve when i run nslookup on my local DNS server.

  • Ok so I went ahead and restarted the service and I'm still having issues resolving this server name. I'm out of troubleshooting options. Also cleared the cache and still didn't work. Any other ideas? – Jim Jun 8 '10 at 20:15
3

The response may be cached locally. Try ipconfig /flushdns to clear the local cache and try the query again. If you're querying the local DNS server directly, you may need to clear the server's internal resolver cache using dnscmd /clearcache before it will use the new forwarder for that query.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.