Half of my ZFS filesystems are hidden in ZFS-fuse. Here's my story:

So, I love ZFS. I used it for about six months on FreeBSD, but due to it crashing the kernel during heavy inter-filesystem IO load, I tried switching to Solaris 5.10.

That was good, but when I attempted to do an import of my Version 13 pool into its Version 4 version of ZFS, there were some heafty problems. It may have tried to correct the filesystem definitions, I don't know.

Since that version wasn't compatible with my pool, I've now switched to Ubuntu Server 10.4. That version more than supports that of my pool, but I can only see half of my filesystems. The filesystems I can see are the same as those Solaris could see.

Now, despite those filesystems not being preset in a 'zfs list' command, I can still set properties on them and I can even still mount them and read and write files, but they just plain don't show up in 'zfs list'.

I've mounted the major ones, but I'm not sure what other filesystems there are anymore (I have about eight that I can't see).

Anyone have any idea what the heck is going on? I think I might try booting back into FreeBSD 8 (I still have the main boot drive laying around for that) and see if at least it is able to view the filesystems.

I've also done a scrub while in Linux, and it found no errors with any of the data. Oddly, DMA read errors which caused problems on FreeBSD ZFS are reported by Linux, but ZFS-fuse doesn't find an error. That's a topic for another post however.


Instead of Solaris 10, Linux/ZFS-fuse or FreeBSD, I would use the latest dev opensolaris build (build 134 as of today) which has the more up to date ZFS code included to diagnose what the issue might be. Please post the output of "zfs get all 'invisible-filesystem'" to see what property might prevent some of them to show up.

| improve this answer | |
  • How stable are the dev builds of OpenSolaris? I could grab a copy just for the diagnostic tools, but I'm not terribly comfortable installing it as a permanent solution. – RandomInsano Jun 12 '10 at 18:31
  • 1
    They are probably more stable than any non Solaris OS providing ZFS support. I have been exclusively using OpenSolaris development builds for more than five years as my main personal/work OS without any noticeable issue. I was however only suggesting using it for diagnosing purpose. If you are in production and need formal support, Solaris 10 is probably the most reasonable solution. – jlliagre Jun 13 '10 at 7:54
  • Turns out I've been using zfs-fuse since I posed the above question and it's worked extremely well. However, Sol11 is out, and I cooked my Linux drive by accident so I'm trying Solaris again. Fuse turned out to be a decent solution, plus I had an enormous (biggest?) wealth of free software to choose from. – RandomInsano Nov 28 '10 at 1:40

"due to it crashing the kernel during heavy inter-filesystem IO load"

That may not be the the FreeBSD kernel, but the 3+ years bug with ZFS ARC that still persists!


(This one is nasty as it will also go out-of-bounds from the VM limits of a hypervisor!)

| improve this answer | |
  • Did you even read that bug report? It had nothing to due with crashing or IO load. From all of the previous ZFS-related comments you've left this evening, it seems as if you perhaps have a personal vendetta against it. – EEAA Jul 26 '10 at 2:16
  • See my comment and working stop-gap at serverfault.com/questions/162693/… – user48838 Jul 26 '10 at 2:45
  • IMHO If you use a bug report which has basically no relation to the question asked you should explain a lot more instead of just posting the link to the report. I do see how the bug described in the bug report could be relevant to the problem but the report in it self is not. – Marcel G Oct 21 '10 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.