I'm running exim4 as my MTA and it works great to send emails to outside emails other than my hostname.

When I send an email to my gmail via command line (sendmail forgedtuts@gmail.com, etc...) it works fine.

When I send an email to my website's domain, which is also the hostname for the server, i'm assuming it just does local delivery... which won't work because my email is received by another server (Google Apps).

So how do I disable local delivery in Exim4? dpkg-reconfigure exim4-config did not give any real results.

  • 1) a smarthost use of Google Apps seems to set the reply-to as the authenicating account so if you are trying to have your web site send mail it will always come from your Google Apps account. At least this is what seems to happen 2) I'm trying to use a contact form so the reply-to has to be the email address the user enters in the form My understanding is that I cannot use a smarthost and that I therefore need to find another way to disable the local delivery. There must be a config setting, maybe something not in the dpkg-reconfigure settings?
    – user70010
    Feb 8, 2011 at 20:50

2 Answers 2


Run dpkg-reconfigure exim4-config, select mail sent by smarthost; no local mail and fill out the asked information.


You're server's name should not be the domain name... it should have a hostname like "server" under your domain "example.com", so the FQDN is "server.example.com".

  • Tried, and failed, unfortunately. Apr 14, 2012 at 2:19
  • @JulianH.Lam You must have exim configured to think it is responsible for the domain then. Also, if you have a Question please use the "Ask Question" button in the upper right corner of every page.
    – Chris S
    Apr 14, 2012 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.