Is there any method to backup Exchange 2007 bases with Symantec/Veritas Backup Exec 12.5 using GRT (Granular Recovery Technology, as i remember) in our situation, described below.

What we have: 1) 2 different networks, 2 domains without trusts. Each domain have one Exhange 2007 SP1+RU8, installed on Windows Server 2008 with SP2 (x64).

2) Backup Exec 12.5 with SP2, installed on Windows Server 2003 with SP2 (x64). Server is standalone (not domain member), with two NICs in our 2 networks.

3) HP's tape library with one LTO-3 drive.

With Exchange 2003 in both domains - it's just worked, but after migration to 2007 - GRT is broken (snapshot-based backup is working)...

MAPI Client and CDO installed at exchange servers, but what to do with Exchange Management Tools, that must be installed at backup server? As far as i know, EMT can only be installed at domain member computer, but what to do with second domain?

Is there any chanses to resolve problem without purchasing additional software/hardware?

P.S. Sorry for my bad english...


Have you confimed that this is only an issue due to the lack of domain membership? If you are running Exchange 2007 on Windows 2008, then there is a different version of the MAPI/CDO client that needs to be installed.

That is available for download here: www.microsoft.com/downloads/details.aspx?FamilyID=E17E7F31-079A-43A9-BFF2-0A110307611E&displaylang=en

Personally, I would try adding your BE 12.5 server into the domain of one of your Exchange 2007 servers and verify that GRT is working (or not) to rule out other issues.

  • Is exact same version of MAPI/CDO, as installed on our servers (link is found earlier at Simantec's support site). I'll try adding server to domain at next week, but not sure is it helpful, because I don't know, for what installation of Exchange Management Tools on backup server is necessary... – Serg K. May 29 '09 at 21:18
  • I can confirm that you do not need the management tools on your Backup Exec server when doing GRT with Exchange 2007 SP1. We are running the same setup here (BE 12.5, Exchange 2007 SP1) with GRT. – Doug Luxem May 29 '09 at 22:14
  • Thanks a lot for hope, DLux. If it works for you, I'll try to achieve its working for us. – Serg K. May 30 '09 at 17:24

The problem is solved. Exchange Management Tools really it is not necessary on backup-server, as well as has told DLux, and against to statements on a Symantec's support site. In my case the problem was solved by recreation of the account for backup agent, copying from account of Administrator. Probably the problem was in shortage of some rights, It's difficult to tell which.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.