I am trying to get IIS 6 to serve up PHP pages.

I have followed: http://www.iisadmin.co.uk/?p=4&page=3

But now with PHP 3.2 I dont see PHPisapi.dll anyplace so it doesn't work.

Does anyone know what I might be doing wrong? I downloaded the .zip for 5.3 Windows non-thread safe and manually put in at c:\PHP.

I am stumped.


Would this tutorial (using FastCGI as opposed to ISAPI) help?

  • @ircmaxwell - I have always read that FastCGI does not function as well as ISAPI – ELS Jun 14 '10 at 18:30
  • Not always true: forums.iis.net/t/1146597.aspx Not to mention that FastCGI is LOADS more stable (since there are a lot more servers running FastCGI than there are ISAPI for PHP)... And not to mention that the MS recommended SAPI for IIS7 is FastCGI... That should tell you something ;-) – ircmaxell Jun 14 '10 at 19:05
  • OK, I tried the automated install which says it was successful with no luck. I put a index.php in my default site and added index.php as the only document to be served. I supposed I should try a manual install now – ELS Jun 14 '10 at 19:54

Call me lazy, but I really think Microsoft's Web Platform Installer makes IIS/PHP (along with MySQL) installation and configuration so much easier than the old & manual way. Check a few boxes and let it do the rest.

  • I did this, it wasn't working, so I went through manually and everything is set right, but I try and hit my default site and I get a page not found (404). It does exist. If I put an index.html it works, if I put an HTML and re-direct using JavaScript to index.php I still get a 404. I believe my permissions are correct. – ELS Jun 14 '10 at 20:14
  • If it failed when Web Platform Installer tried there may be a bit more going on than you've shared? In IIS Admin, is PHP listed under Web Service Extensions? (and is it enabled) – Chris_K Jun 14 '10 at 21:31
  • yes under Web Service Extensions I have: FastCGI Handler and it is Allowed. What other questions can I answer to get more help? – ELS Jun 14 '10 at 21:59
  • I am, for the moment, quite stumped as to what to suggest next. Make sure no FPSE is involved on the server, check to ensure you have MIME type for PHP configured? – Chris_K Jun 15 '10 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy