I recently created an Intranet application for my company, but to work properly it must execute an ActiveX control to locally run a program.

However, the only way I found for this to work was using Internet Explorer, and setting Intranet security to a personalized "very low" configuration for being able to execute ActiveX scripts without asking.

I think there is a way to automatically configure IE's settings for all users from Active Directory, but I can't find it. Any help?


You'll want to push these out through Group Policy. In GPME, User Configuration/Windows Settings/Internet Explorer Maintenance are some options for security and URL options. In User Configuration/Administrative Templates/Windows Components/Internet Explorer are more settings that you can customize. Since you didn't specify what level domain you're in, I'll say that I pulled this from a 2008 DC, but the paths should still be the same.

  • In our case Group Policy Management Editor (GPME) is located at: "Start" > "Programs" > "Administrative Tools" > "Domain security policy.msc". Otherwise: "Start" > "Run" > type: mmc+ <kbd>Enter</kbd> > menu: "File" > "Module add/remove" (<kbd>Ctrl</kbd>+<kbd>M</kbd>) > button: "Add" > "Group Policy Managment" > button: "Add" > button: "Close" > button: "Ok". Note: You can save this preset from the "File" menu. Expand: "Group Policy Management" > "Forest: ..." > "Domains" > your domain name > "Group Policy Objects" > right click "Default Domain Policy" > "Edit". – Pro Backup Mar 15 '14 at 13:03

You may want to look into setting up some policies for that. I would put that site into the trusted intranet zone and through policy again adjust those settings.


You could...

  1. Roll out the control using a Electronic Software Distribution tool (SCCM, LanDesk).

  2. Use the ActiveX installer service on Vista/Win7 Clients (http://technet.microsoft.com/en-us/library/cc721964(WS.10).aspx).

We use both

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.