A drive failed on a Dell SAS 5i controller - see controller bios screengrab: http://imagebin.ca/view/SkZbszA.html

The primary is a 160GB 10k sata drive.

I added a 250GB 7k rpm drive in the hope that the array would rebuild onto this drive. This did not happen. (assuming that the controller would just operate at the speed of the slowest drive)

The controller could see the new drive, but it didn't automatically rebuild the raid1 onto this drive. (my assumption is that it did not do this rebuild as the drive sizes are different).

There was an option to add the new drive to the existing raid1 array - but when I tried this a message appeared stating that all data on the array would be lost. (I didn't get a screenshot of this message, I will later)

Should the SAS 5i allow me to rebuild the array onto a larger drive?

Is the option to add the drive to the array the right way to go?

Many thanks!


2 Answers 2


It should allow to rebuild onto a larger disk, how exactly did you try to initiate the rebuild? The proper way is to set the new disk as hotspare, and then a rebuild should start automatically

  • I can't see any mention of hot spares in the controller BIOS, and googling the terms it shows that the SAS 5IR doesn't seem to support hot spares. en.community.dell.com/support-forums/servers/f/906/p/19149494/… There's an option to "Add Disk" to the existing Array.. (imagebin.ca/view/skdg3Ym.html) but I'm worried about this possibly destroying the data on the original drive..
    – Kenny
    Jun 17, 2010 at 12:52
  • I don't have a simulator for this controller handy here, but I definitely remember there being an option... have you tried using OMSA instead of the controller BIOS?
    – dyasny
    Jun 17, 2010 at 12:56
  • I haven't tried OMSA, it's a desktop machine.. imagebin.org/101627 - there's "Manage Secondary Disk" from which I can add the new disk "imagebin.ca/view/skdg3Ym.html" - but I'm sure I can't see anything about hot spares..
    – Kenny
    Jun 17, 2010 at 13:21
  • The Dell documentation talks about the option for managing the secondary disk in the IM volume... "Manage Secondary Disk This option is used to add a secondary drive to a degraded IM virtual disk with a missing member. " from: public.support.unisys.com/pcproducts/esx/docs/DellDocs5.4/en/… My bios screenshots: imagebin.ca/view/skdg3Ym.html imagebin.ca/view/sgsoUdlC.html So is this safe to do in our case, which is a degraded IM virtual disk with a missing member...?
    – Kenny
    Jun 17, 2010 at 13:39
  • It could work, but if I were you, I'd call Dell support and ask them to give me the exact instructions for doing this
    – dyasny
    Jun 17, 2010 at 17:08

SAS 5i/R definitely supports 'hot spare.' BUT, the whole RAID ability in the controller is very non-intuitive. I should be able to take a BRAND NEW, exact same model drive, and just plug it in - where I removed, let's say, a 'bad drive' - and it all should work, but it does not seem to see/use the new drive, depending on how it is formatted and so forth.

And it seems you can up to 4 RAID configs on one SAS 5i/R card? You can scroll through them, with Alt-N. This is SAS 5i/R in a Dell PE 860, and no, there is NOT any option to 'add a drive,' not in my config, not with latest firmware and drivers and so forth - if there was, that would be perfect! Adding a hot spare did work at one point, but now it just sees "failed raid drive" and won't let me add it.

I was even able to synchronize, briefly. I did a whole 'synch,' thinking I could take the secondary drive (Drive 1 in my case) and plug it into a 2nd Dell 860 and all would be perfect (like 'imaging' - build several copies and use them in my multiple other servers - which I am licensed for), BUT, it lets the other server BOOT from the "synched" drive, but not re-establish the array.

Even on the SAS Controller page, it shows "Create IM volume - you can copy the data from Volume 0 to 1" (not those exact words, but you get the idea), but that is NOT true! On a "Create RAID," it always "WIPES OUT" the drives and re-creates the entire mirror! BAD, very BAD! There ALWAYS should be an option to add back a drive, if one goes bad, and Dell failed on this task, because there is NOT an easy way to do it!

There is "Manage Array" but no "manage secondary drive" option like you are mentioning. And OMSA does not allow changing of the 2nd physical drive that has not yet been added to the array - just very weird - I am running W2k3 Server Standard R2 64-bit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .