I've been trying to compile mutt under cygwin for a few days. The included version is outdated and does not include things I need like header caching. Anyways, I always get the message:

"configure: error: no curses library found"

I have all the curses + devel stuff installed + termpcap, which I heard might be related. I've tried re-installing, i've tried specifying the location on the configure command line, but i'm not sure i'm doing it right:

"--with-curses=/usr/lib/libncurses.a --with-curses=/usr/lib/libncurses.dll.a --with-curses=/usr/include/ncurses"

Here's my config.log:


Any ideas?

EDIT: Context

closed as off-topic by user62491, voretaq7 Nov 11 '13 at 18:22

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Community, voretaq7
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Why, oh why, would you want to use Mutt on Windows?? – Chris S Jun 17 '10 at 18:51
  • 4
    Because mutt is awesome... wish i had an answer though, not familiar with windows + cygwin compiles – cpbills Jun 17 '10 at 19:11

It looks like your environment is messed up.

configure:11329: gcc -o conftest.exe -g -O2   conftest.c -ltermcap   >&5
C:\Program Files\Haskell Platform\2010.1.0.0\mingw\bin\ld.exe: cannot find -ltermcap

Your building form cygwin, but it's roping in mingwin build tools from your "Haskell Platform" program?

try prefixing your command w/ the env utility, try this in cygwin:

env -i PATH=/usr/bin:/usr/local/bin:/usr/sbin:/usr/locals/bin ./configure
  • This sounds like it must be the issue. Thanks so much helping me nail it down. The command above does not help but I imagine I have to clear out the PATH variable and make sure it does not include any haskell stuff. I'll work on figuring that out. – math0ne Jun 18 '10 at 10:41
2 is part of cygwin, if you select it in the mail package section.

  • +1 i kinda figured there would be an existing mutt package for cygwin... – cpbills Jun 17 '10 at 19:16
  • It's hard to find packages with Cygwin. This is one reason why one of the project leads for Cygwin said "setup.exe sucks". – Stefan Lasiewski Jun 17 '10 at 19:21
  • 1
    What's so tough about typing "mutt" into the "Search" window in the Select Packages dialog window? Or expanding the Mail category and finding mutt alphabetically? Or, if you didn't know mutt was email, toggling the View to Full and finding mutt in the full list? – mfinni Jun 17 '10 at 20:44
  • mutt is terribly outdated and missing some specific features I need such as header caching. – math0ne Jun 17 '10 at 22:44

As it happens, Cygwin's mutt package was updated to 1.5.20 with support for Unicode and other character sets yesterday.


This might help:

  232  ./configure  --help | less
  233  ./configure  --enable-smtp --with-regex --with-ssl --enable-pop  --enable-imap --with-mailpath=/var/spool/mail --enable-hcache --with-sasl
  234  make clean; make
  235  ./mutt
  236  make install

Unfortunately Cygwin has not complied mutt with smtp_url enabled in the 1.5.20 build.

–enable-smtp and –with-sasl

So I would not be able to send email with smtp auth, with out installing something else, at the moment I just ssh into a server at base and do it.

If I find the time I will have a go at building mutt under Cygwin.

However, I will probably just install a ubuntu server vm, since I would rather learn more about ubuntu than mess around with Cygwin. Thought mutt would at least be up to date in Cygwin.


If you want to compile 'mutt' for Cygwin, and be able to access services such as Gmail, do the following:

  • From a base install of Cygwin, install the following packages:
    • mutt (source)
    • automake
    • openssl
    • openssl-devel
    • libsasl2-devel
    • make
    • gcc
    • ncurses
    • libncurses-devel
    • gdbm

Once these are installed, locate the source package in '/usr/src/mutt-1.5.22-1'(1.5.22-1 is the latest version at the time of this writing) change into that directory, and run the following:

  • $ cd /usr/src/mutt-1.5.22-1
  • $ ./configure --enable-imap --enable-pop --with-ssl --enable-smtp --with-homespool=mailspool --enable-hcache --enable-debug --with-sasl

If all goes well, you should have a working implementation at '/usr/local/bin/mutt'

You can use your .muttrc from the *nix side of things with little trouble.

Not the answer you're looking for? Browse other questions tagged or ask your own question.