I am new to kvm. I have this strange issue. But before explaining the issue, here is my set up.

I try to install VM on my Host which is a Acer Laptop 5720 Intel Core 2 Duo T7500 processor. The cpu flags indicate that Virtualization is supported. I run Ubuntu 10.04 (lucid) which comes with kvm.

Now coming to the issue - I dont get any errors while executing "sudo modprobe kvm-intel". So I presume my processor does indeed support hardware virtualization.

I use virt-manager and create a VM on which I install ubuntu from an *.iso file. When I start the VM it says it is running. No signs of any trouble. I can see the domain listed in "virsh list". But when I try to connect to the VM thru VNC, all I get to see is a blank screen (no cursor). There is no response to any key press. And I am unable to install the OS on the disc. Same happens when I try thru the commandline.

I changed the video mode etc. Tried all different combinations but nothing helps. But strangely, if I shutdown the vm an virt-manager and then unload the module by doing "sudo modprobe -r kvm-intel", everything works fine. ie., I can see the screen via VNC. I am able to install the OS and so on.

So what does this mean ? Is hardware virtualization not supported on my laptop ? How come there is no error anywhere ? dmesg | grep kvm doesnt report anything. Can someone throw light on what exactly is happening ?

  • After you start KVM, what does lsmod show? What KVM modules are loaded? Also, if you run kvm from the command line without any options, do you get any error message? – Dan Andreatta Jun 18 '10 at 16:11
  • lsmod | grep kvm shows the following output kvm_intel 39384 0 kvm 245405 1 kvm_intel simply running kvm on the console pops up a blank screen with the title "qemu" – Sathya Jun 19 '10 at 16:55

check your laptop bios - many vednors install VT enabled CPUs, but disable virtualization in the BIOS. That way the /proc/cpuinfo flags are OK, but kvm can't work properly

  • I tried running securable.exe. It reported that "Virtualization is Locked on". So i beleive it is enabled. My BIOS ( phoenix bios utility) provides no option to enable/disable VT. – Sathya Jun 18 '10 at 11:32
  • try this petri.co.il/forums/showthread.php?t=42782 – dyasny Jun 18 '10 at 13:58
  • KVM require to have hardware virtualization, and he says that he can use KVM, but has to unload the kvm-intel module. – Dan Andreatta Jun 18 '10 at 16:10
  • unless this is a weird version of kvm, kvm_intel has to load as well as kvm – dyasny Jun 18 '10 at 17:09
  • kvm -version outputs QEMU PC emulator version 0.12.3 (qemu-kvm-0.12.3), Copyright (c) 2003-2008 Fabrice Bellard – Sathya Jun 19 '10 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.