This problem lies within a relatively fresh x64 Windows 7 install ~4 weeks, but is also a problem I have seen on Windows Vista machines (x86 versions).

Since the other day, any programs attempted to be launched via right clicking on a shortcut (.lnk)'s context menu and pressing -> "Run As Administrator" for instance, in the Quick Launch/Jump List in Windows 7 has failed, screen has not dimmed, no UAC popup. In fact the program does not even load. There is no way around this unless I use the shortcut version from "All Programs" which appears to work, very strange? I have performed no major software installs, nothing out of the ordinary.

Has anybody encountered this or know what would be causing it?

Here's an example of somebody else experiencing this problem in Vista with no solution: http://www.vistax64.com/vista-general/131918-strange-run-administrator-problem.html
and I believe this problem is related, I also cannot right click -> "Manage" on my computer): http://windows7forums.com/windows-7-support/5501-run-administrator-broken.html

I am running the latest version of Avira AntiVir Virus Scanner and pretty concious of what I download, I don't think it is a virus, nor do I believe it is due to the RC Version of Windows 7, because I have seen the problem across multiple Operating Systems versions.

Thanks guys.

locked by sysadmin1138 Nov 21 '12 at 3:10

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. See the help center for guidance on writing a good question.

Read more about locked posts here.

  • What build on Windows 7? – mrdenny May 30 '09 at 2:33
  • Build 7100. (buffer text for char. limit) – GONeale May 30 '09 at 2:57
  • Isn't this a bit off-topic here? – Massimo Nov 20 '12 at 16:42

I have encountered the same problem in win7. I am a Chinese user and found the cause and solved it by searching in Chinese forums.

Its cause is some buggy(maybe programmed old-fashionedly) softwares that add extra entries in the right-click context menu, with a DLL as the context menu handler.

Possible causing softwares includes: NamiRobot (http://www.namipan.com/); old version Tencent RTX (http://rtx.tencent.com/)

You can check your right-click context menu and see if there are any strange items that do not belong to Windows 7. In my case it is the NamiRobot that adds one item in the context menu for all file types.

I also have these context menu items and they are fine: Adobe PDF; WinRAR; Kaspersky; WinHex; UltraEdit; EmEditor; UltraISO.

There are rumors that Sony DVD software also causes this problem, I don't know whether it is true.

So the solution is either to uninstall the software, or unregister the context menu handler DLL and remove the context menu entry.

For NamiRobot, I manually fixed in the following steps:

  1. open an elevated command prompt(start -> all programs -> accessories -> command prompt, right click -> run as admin)
  2. run the command: regsvr32 /u "C:\Program Files\NamiRobot\Data\NamipanExt1.dll"
  3. run regedit.exe, delete the following keys:
    HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\NamipanExt HKEY_CLASSES_ROOT\CLSID\{5696473A-FC50-4CA7-B87A-AF60201B04DD}

The three steps are enough to fix the problem. To prevent the software screwing up the context menu again, you may want to do the following: First rename the original NamipanExt1.dll to "NamipanExt1.dll.bak", then create an empty txt file in the same directory(C:\Program Files\NamiRobot\Data), finally rename the txt file to "NamipanExt1.dll".

Hope you find your causing software and fix it!

UPDATE: other softwares causing this problem:

CompareIt(according to imasu49)

CopyPathEx(according to Peter, see below)

  • Interesting response, I have not run into this since my last RTM format, but if I do I will be sure to let you know. – GONeale Mar 7 '10 at 22:44
  • Thanks for this solution !! Also add BidDaddys' EmlOpenView to the list. Removing the context menu from within the application itself fixes the problem. – Ryan Shripat Nov 24 '10 at 15:04
  • emlOpen View issue should be fixed in v3.7: "Still working to resolve the shell extension menu problem that is causing the “run as administrator” issues. Should be resolved early in the 3.7 builds." – Ryan Shripat Nov 29 '10 at 15:21

Shot in the dark... do you need to hold shift like you would with XP?


When you say "unless I use the shortcut version from "All Programs" which appears to work" do you mean that you run as administrator there?

Perhaps GPO or someone has turned off or otherwise played with UAC settings.

Try Start --> msconfig --> tools --> enable UAC --> launch

this will reset it.

Another stupid question, but sometimes the "I want to complete this action" hides under another window. That got me at least a few times (including just now testing msconfig)

take care, -Mathew

  • +1 that seems to have solved my problem. – rsenna Apr 14 '12 at 20:42

Just for everybody who might encounter the same problem I stumbled upon a solution for an interesting problem concerning a non-working "run as admin" context menu. Since I couldn't find a description of this setting anywhere else, I describe the solution for everybody else who might have the same problem.

The setting: Windows 7 on a netbook, several different users, one admin (me).

The guessed soolution: Set up one admin account (not the built-in one), set up one user account, hide the admin account from the login screen via a regedit tweak as described elsewhere.

So far, so well. Now the embarassing problem: The moment I hid the admin account, the run-as-admin context menu was no longer working. Saying this, I could select the option from the context menu but the upcoming window didn't contain any longer a password prompt.

Importing the previously exported reg-file didn't work as a non-admin, safe mode didn't bring a solution, activating the build-in admin account wasn't possible without running cmd with admin-rights.

Creating an elevated short-cut via task planner wasn't wworking as well and running regedit with the runas command didn't work either.

The solution: Running a second instance of cmd from a standard cmd prompt with the runas command. From this freshly created admin instance of cmd running regedit to change the registry key manually in order to show the hidden user account.

Not the answer you're looking for? Browse other questions tagged or ask your own question.