restored an sbs 2003 backup file to different hardware rebooted, and things took a while, i tidied up the drivers and such, removed ghost nic in device manager etc, re-ran the connection wizard for internet without issues.

i hard coded the ip address like it was previously on the other hardware.

from the server i can ping myself and nslookup for items in the forward lookup zone (like pc's) resolve correctly.

if i try to acquire an ip address from the server, since it was dhcp enabled service on the server, i don't get an ip address i get one with octets 169.x.x.x. etc.(this is by using a notebook on a switch and waiting for dhcp request to be broadcast)

if i hard code my notebook with same subnet i cannot ping the server ip address of

if i try to rdc ot the server it fails, there are no firewalls etc..

what am i missing? are there any suggestions for restoring to different hardware that i may have missed? this is an exercise to verify that the backup is working properly, the data is fine but i would really like to be able to get the networking fixed.


  • Check to see if the dhcp service is running. – tony roth Jun 22 '10 at 22:16
  • did not try that but i would assume it is running if the scope shows up and it has a green up arrow on it? – user8256 Jun 22 '10 at 22:37
  • any dhcp errors in the event log? – tony roth Jun 23 '10 at 13:57
  • no dhcp errors see my answer below as to how i fixed it – user8256 Jun 23 '10 at 23:08

Does the version of Ghost you're using support restoring to dissimilar hardware? If not, then I'd say that's your problem. If so, try removing all NIC's from Device Manager then reboot and see what happens.

  • Hmm... I assumed you were using Ghost because of your reference to a ghost NIC. That may not be what you meant? What software are you using to restore the server? – joeqwerty Jun 22 '10 at 22:27
  • ok, i installed on new hardware the sbs 2003 with sp2 (just like the original one). then i logged back in to desktop from clean install. Then i ran ntbackup, catalog the backup, restore c drive and system state. Rebooted once done. so now i am at the exact desktop and data file set that the other (production) server has. it is basically a 1:1 match of the production server but i can't get anything off the nic to work. The ghost nic is the hidden nic from the old server (an intel giga nic), i am using a realtek giga nic in the dissimilar hardware test. thanks again. – user8256 Jun 22 '10 at 22:35
  • i basically went into device manager and deleted the hidden nic – user8256 Jun 22 '10 at 22:36
  • I don't think it's an officially supported scenario to restore an entire system to dissimilar hardware using ntbackup. This article may help though: support.microsoft.com/kb/249694. If all else fails you can try removing all NIC's from Device Manager and remove all entries in the registry related to the NIC's. – joeqwerty Jun 22 '10 at 22:56
  • i have successfully done this before with other clients, this one is the first one i have had an issue with so i am looking to see if there is any obvious places in the os/settings that i need to look at? – user8256 Jun 22 '10 at 23:12

thanks for everyones help but here is the solution

  • did everything i normally would of done to dissimilar hardware
  • checked dns and active directory
  • set static ip address of new nic card to the same old static ip address
  • found that i could ping from server the router/gateway and a static ip'ed notebook on the switch
  • found that i could not ping from notebook to server, BUT could ping from notebook to gateway, so it lead me to believe that there might be a routing issue or firewall or something blocking the connection back to the server
  • from the server \localhost worked and it showed the files it was offering so sharing was working
  • went to administrative console, rras and disable or unauthorized it
  • tried to authorize rras so i can configure nat from fresh, error about firewall service running
  • ran services.msc and located Windows Firewall server and set to permanent disable
  • ran the ceicw wizard and it finished like before.
  • went back to rras and authorized or re-configured a new connection
  • chose the connection in rras of "configure nat"
  • clicked on finish
  • re-ran ceicw
  • disabled dhcp and re-enabled it

  • plugged in notebook and about 10 seconds later i got an ip address in the subnet i was expecting, looked under dhcp "address leases" and there was my notebook with it's ip address

  • tried rdc from notebook to server and it worked

  • tried \sbs-server and it offered up the info i was looking for, actually tried it from my mac so it was smb://sbs-server, was able to log into server with admin creds.

  • went to terminal window and did a dig sbs-server, came back with proper Host A record to ip address mapping

  • did an nslookup and randomly picked computer names in active directory that were in the forward lookup zone for the .local DNS internal and all resolved back ot the records that the server.

what did i learn? well 2 days of digging to find out that my hunch for sourcing routing issues is where i should of focused vs thinking it was a restore issue on my part.

once again go back to your hunch or gut feeling as it is 99% right all the time.

hope this helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.