2

I had a 1.5TB hard disk in a Windows 2003 Server. Two partitions, one FAT and the other NTFS.

The server crashed, and while we are ordering a new one, I would like to access the data on that volume. However, when I attach the drive to my Windows 7 64bit desktop, the entire NTFS volume shows up as Access Denied. (The FAT volume is accessible just fine.)

In Explorer, the volume shows up with no info:

Explorer

In Logical Disk Manager, the volume appears with no info:

Disk Manager

I tried running TAKEOWN on the volume, but since the entire volume is inaccessible, it didn't work:

TAKEOWN

I also don't have permission to take ownership using the Windows 7 GUI:

GUI Access Denied

I have the username, password, and SID of the owner from the server where this volume was previously. The volume was not encrypted and was not compressed.

How can I gain access to this drive?

2
  • I'd really want to try putting it into a Linux machine and create an image of the drive before trying to "retrieve" data from it, maybe access the files from the image instead before doing something that can damage the information on the drive. Aren't there backups you could retrieve from? Jun 23 '10 at 13:54
  • +1 Had the same problem using an external drive previously mounted in Windows XP, but the PC was dead, and had to copy the files. I couldn't because of ownership, particularly. I have used icacls as stated in my answer which helped me, without having to reboot or to use anything else. This knows some limitations under certain conditions, though. Dec 2 '10 at 15:13
4

If you are logged in as an Administrator your should be able to take ownership in the owner tab of that last screenshot and then change permissions. Or, if this doesn't work, you could download a Linux boot CD and access the files that way.

7
  • Linux is what I was thinking of, too. Boot up a live CD, mount the NTFS partition read-only, and copy the contents. Jun 23 '10 at 13:57
  • 1
    +1, taking ownership will fix this issue.
    – ITGuy24
    Jun 23 '10 at 14:26
  • Sorry, I forgot to add the final image, which is that access is denied when taking ownership.
    – Portman
    Jun 23 '10 at 14:55
  • 1
    Is the account you are using a local administrator?
    – rybl
    Jun 23 '10 at 15:24
  • Yes, the account is the local administrator.
    – Portman
    Jun 23 '10 at 22:21
1

Using the command-line prompt with the Icacls instruction might help also, just to let you know. I have tried it already, no later than lastnight, and worked quite well.

For example:

icacls "[drive]:\Full path" /setowner %USERNAME% /t /c

This above instruction will change onwership for all of the folders and files from the specified full path and all subfolders and files. The /c tells the tool to continue on error, so that it can process all it can.

icacls "[drive]:\Full path" /grant %USERNAME%:F /t /c

This above instruction grants FULL (:F) access to the specified filepath.

Besides, the Linux Live CD is also a neat solution.

1
  • Thanks, just had to make sure you run the cmd.exe as adminstrator but these commands worked for me with this exact same situation and was able to recover my files from a windows 8 rc box
    – Mouffette
    Jul 18 '12 at 16:46
0

I had the same issue except I wasn't able to see the Security tab at all when accessing the properties of the disk. I managed to lock myself out of it (being my laptop's only hard disk) when I tried to resize the C:\ logical disk (stupidly, admittedly ;)) but managed to corrupt it, to which Check Disk fixed it but buggered the NTFS permissions.

I found that TakeOwn does work on logical drives, but you have to be careful about what syntax you declare in the command prompt. You wrote in your screenshot "J:\", drop the "\" and TakeOwn will pick up the drive.

I'm still locked out though. Hmm...

1
  • 1
    However, accessing the disk through Disk Management displayed the Security tab (after turning File Sharing Wizard off too). Yay!
    – Justin
    Dec 2 '10 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.