My mail server(Postfix) is messing around a bit. It seems that it does receive the messages it receives but it doesn't store them? I'm not quite sure of the reason, because it worked fine last time I checked(when I first set it up, about a month ago).

from /var/log/mail.info I receive this:

Jun 25 13:23:14 lisa postfix/qmgr[24281]: 37F3D3DC2A7: from=, size=2024, nrcpt=1 (queue active) Jun 25 13:23:14 lisa postfix/local[29814]: 37F3D3DC2A7: to=, relay=local, delay=0.55, delays=0.35/0.01/0/0.18, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME) Jun 25 13:23:14 lisa postfix/qmgr[24281]: 37F3D3DC2A7: removed

In a way, from what I can see with that; I think it's either putting all mail into a queue or just deleting them entirely.

Daemon log doesn't reveal anything, and neither does the mail error log. I'm using Dovecot with Postix as well. Could anyone "enlighten" me as to why this is happening?

1 Answer 1


A MTA does not 'save' messages (it may keep them on disk temporarily while it tries to find another program / server to take the message) for messages terminating locally, it hands them over to a MDA for delivery. This is what your log entry shows. It also shows that it it successfully handed the message over to procmail for delivery. So there does not appear to be anything wrong with postfix.

The problem is either with procmail or dovecot.

If it worked previously, check /etc/procmailrc and ~/.procmailrc for changes. I'm not familiar with dovecot - presumably your procmail is (or should be) configured to chain a third program to get message into dovecot. This seems rather inefficient.

Alternatively it could simlpy be that the postfix config is wrong and routing some emails to the procmail MDA and some to an MDA which puts it in dovecot.

Try changing your ~/.procmailrc file to dump a copy of every email into a file (see the procmailex man page for an example of how to to do this).



You must log in to answer this question.