I can't access web content (like a simple HTML file) on my Windows 7 Ultimate x64 machine, either locally or remotely. I tried connecting to IIS (running on port 80) and the built-in Visual Studio web server (running on port 23456) but for some reason, the request never makes it to the web server and both IE and Firefox timeout. The firewall and antivirus have been stopped. I tried accessing the web server using http://localhost, and and none work. The hosts file looks like this:       localhost
#   ::1 

I tried commenting out both lines and un-commenting both lines. No difference.

So I assume something with the networking stack must be screwed up on this machine. Any advice on diagnosing/fixing this?


Are you sure the web server are running? Type the following commands in a command prompt:

netstat -an | find "80"
netstat -an | find "23456"

If the web servers are running, you should have a similar output:

C:\Documents and Settings\Benoit>netstat -an | find "80"
  TCP                 LISTENING

By the way, if Visual Studio web server is running on port 23456, you must use the following URIs:

According to your output, it really seems a firewall is running on your computer. Have you tried to connect from another computer on your network?

  • Yes, I was using the port numbers for the VS web server. Here's the netstat output: C:\>netstat -an | find "23465" TCP SYN_SENT TCP LISTENING C:\>netstat -an | find "80" TCP LISTENING TCP [::]:80 [::]:0 LISTENING Looks good right? – Sajee Jun 26 '10 at 21:16
  • Sorry abt the formatting. – Sajee Jun 26 '10 at 21:16
  • 1
    @Sajee - That SYN_SENT is interesting, seems to indicate that, at a basic networking level, the Windows kernel is not responding to the connection. I think you're spot on when you say there is something wrong with the networking stack. Unfortunately I don't know too much about troubleshooting beyond that. Best of luck... – Kyle Smith Jun 26 '10 at 21:34

I turned the firewall off on this machine. I assumed it would stay off and no ports would be blocked. But this is a domain joined machine and group policy turned on the firewall within minutes of me turning it off, behind my back. So I opened up the ports and now everything is working.

Thanks to those who tried to help.


My next troubleshooting step would be to telnet to the port on a command line. Other thoughts:

  • Proxy configured in Firefox and IE? (There is usually an option for 'skip proxy settings for local traffic', if so. Use that)
  • Windows Firewall enabled?

I don't know if 7 has 'telnet', because I think they removed it from Vista. You could grab a copy of PuTTY and try to make the localhost connection to port 80.

  • No proxies set and firewall is off. – Sajee Jun 26 '10 at 21:18
  • Putty telnet-ing to port 80 also times out. – Sajee Jun 26 '10 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.