Am at a complete loss with this one. Recently a number of my powershell scripts have started failing as they are unable to find the command dnscmd.exe.

What has me at a loss is that the executable exists and works and I can run it just fine in the command prompt. I have tried the following in powershell to run the command:

  • dnscmd
  • & dnscmd
  • & dnscmd.exe
  • & c:\windows\system32\dnscmd.exe

All return "The term dnscmd is not recognized as the name of a cmdlet, function,script file or operable program...."

Can anyone enlighten me as to why powershell is completely unable to see the command, where the normal command prompt/windows explorer etc.. can? Using powershell 2.

  • 1
    are you sure that you have the dns admin tools loaded on "this" particular workstation/server? – tony roth Jun 28 '10 at 20:24
  • Yep, I can confirm the admin tools are installed. I run them just fine from the command prompt on the same machine. – Ben Short Jun 28 '10 at 22:53
  • My issue was that I ran it on a DC that I had not promoted yet. No DNS tools. – Mike Christiansen Jul 1 '14 at 10:19

This sounds like the work of the File System Redirector to me. Are you running on a 64bit OS?

For example, when you make a call to C:\Windows\system32\dnscmd.exe on a 64bit OS using PowerShell (x86), this will be redirected to C:\Windows\SysWow64\dnscmd.exe. The redirection occurs at the point the folder is accessed so even though you are explicitly providing the path to the executable, you'll still be diverted. This can be disabled on the current thread via calls to native Windows APIs or can be avoided through the use of certain variables and aliases.

More information here: http://msdn.microsoft.com/en-us/library/aa384187%28VS.85%29.aspx


Its the File System Redirect, but you can bypass

Instead of


(which the redirector will grab) use

  • oddly the Windows 7 & Windows Server 2008 machines I am testing this on do not recognise the SysNative alias. Any thoughts on why this may occur? :) – Ben Short Jul 16 '10 at 0:04
  • Scratch that - found out it was because I was running 64 bit Powershell, and not 32, which meant the Wow64 layer was not kicking in. – Ben Short Jul 16 '10 at 0:31

What do you get when you execute:

Get-Command dnscmd.exe -CommandType Application

  • Get-Command : The term 'dnscmd.exe' is not recognized as the name of a cmdlet, function, script file, or operable progr am. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. – Ben Short Jun 28 '10 at 22:52
  • Just a link to a screenshot - dl.dropbox.com/u/8408796/dnscmd.JPG Confirmed that c:\windows\system32\ is in the powershell path. – Ben Short Jun 28 '10 at 22:59

This is not very timely, but in Windows 8.1 I have found that it looks for it in System32 but doesn't find it. Strangely it exists on the system, but in the winsxs directory instead. Copying it to System32 allowed it to run as expected. I don't have any explanation as to why this is, but if you hit this issue it may be a workaround for you.

  • You could also add the folder it is in to the path variable. – Falcon Momot Oct 9 '13 at 0:27

I had exact same issue, turns out that I accidently pinned x86 version of PowerShell.

There is really some magic with File System Redirector going on...


just install "DNS server tools" feature. Remote Server Administration Tools -> role based tools -> DNS server tools

  • This is a very old question and it has an accepted answer. Also, your solution doesn't fit the problem, as the DNS tools were installed, they just disappeared. See the accepted answer and the comments to the question. – Sven Dec 10 '14 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.