I've set up a scheduled task on Server 2008 and want to run it as a user other than the local administrator. So I choose a domain account created specifically for this task and once I've closed the scheduled task and entered a valid password I want to run it and look a the history tab for this task. On the history tab I see:

The user account does not have permission to view task history on this computer.

What permission must I grant to allow this user to view history and/or how can I view the history as a local admin/domain admin instead of the user the job will run under?

Steps to hopefully reproduce: I'm starting from the "Server Manager" - Configuration - Task Scheduler - Task Scheduler Library. IN the top middle pane I have tasks that have been running for several months as the local administrator. In the process of troubleshooting another issue I changed the task to run as Domain\ABCuser. Later in the process of troubleshooting I tried unchecking "run with highest privileges". I have since changed the job back to SERVERNAME\Administrator but the history tab still showed the permissions message. I may have had multiple Server Manager windows open. After Closing the Server Manager and being sure no other management consoles were open I was able to reopen the Server Manager and see the History tab without error.

At this point the task works properly but should I ever need to run a task as a task specific account I'd like to know how to make the history viewable. It may be something as simple as closing all Server Manger windows to allow cached permissions to be refreshed the next time you open the Manager but at this point I don't know exactly what the solution is.

  • It's a shame bounty can only be added 48 hours later. I'm ready to add a bounty now.
    – pplrppl
    Jun 29, 2010 at 18:09
  • I'm having a tough time repro'ing the issue to tell you. So I can be sure I'm doing the same thing: I'm logged-on to the server w/ RDP as an "Administrator" when I create the task, using the "Task Scheduler" snap-in targeted at the local computer. I assign an unprivileged user as the user the task should run under. I run the task a couple of times, just to get some history data. Then, I observe the "History" tab and should see the error you're describing. Is that accurate? I can't seem to repro it. Jun 30, 2010 at 21:54

2 Answers 2


You can give regular users or those within a specified group read access to the tasks folder (C:\Windows\System32\Tasks).


Right-click and "Run as Administrator" worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.