0

A client of mine keeps receiving the following email when sending mail but their emails are sent successfully.

Your outgoing (SMTP) e-mail server has reported an internal error... 
The server responded: 451 qq read error (#4.3.0)

In the mail log (/usr/local/psa/var/log/maillog) I receive the following error:

/var/qmail/bin/relaylock[3152]: /var/qmail/bin/relaylock

My SMTP Service is setup as followed, if this helps

service smtp
{
    socket_type     = stream
    protocol        = tcp
    wait            = no
    disable         = no
    user            = root
    instances       = UNLIMITED
    env             = SMTPAUTH=1
    server          = /var/qmail/bin/tcp-env
    server_args     = -Rt0  /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
}

1 Answer 1

1

Have a try with the following parameters in /etc/xinetd.d/smtp_psa and smtps_psa

service smtp
{
    socket_type     = stream
    protocol        = tcp
    wait            = no
    disable         = no
    user            = root
    instances       = UNLIMITED
    env = smtpauth SHORT NAMES = 1 = 1 
    server          = /var/qmail/bin/tcp-env
    server_args     = -Rt0  /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
}

Else try with

Restore all settings without spamassassin:

root# /usr/local/psa/admin/sbin/mchk --without-spam

Restore all settings:

root# /usr/local/psa/admin/sbin/mchk --with-spam

Thanks, Jay

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .