I am migrating a web application from IIS6 to IIS7.5 and I'm having a few strange issues with this.

My web application will serve up .html or .asp pages, but when I try to request a .aspx page it locks up IIS for about a minute or so, and I can't even view the asp page that I was able to view before IIS was locked up.

I've been trying to fix this for about a month and have tried many things but I really can't figure it out.

Things I've tried already:

  • Switching the application pool to the Classic .NET AppPool
  • enabled port 80 and 443 on windows firewall
  • Running aspnet_regiis -i
  • Enabled 32 bit web applications
  • Set Load User Profile = False on my application pool
  • icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant IUSR:(CI)(RX,WD,AD)
  • icacls %WINDIR%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER":(OI)(CI)(IO)(F)

Other notes of interest: When I try edit the markup of an ASPX page in visual studio 2008 in this web application, it hangs visual studio and I have to force end the visual studio process. So I can't edit any aspx pages with the visual studio 2008 editor in the same application. However if I start a new ASP.NET website I don't have any problems editing the ASPX pages. Also, it was originally compiled on Server 2003 32 bit, and I had to enable 32 bit applications in my application pool, otherwise I would get a "not a valid 64 bit application error"

Edit: Also when I request an ASPX page from my broken application, it totally hangs IIS and it won't even serve .asp or .html pages until it either recycles itself or I manually recycle the application pool

Running Software:

  • Windows 7 64 bit
  • IIS 7.5

I am really stuck here, any suggestions would be great. Thanks!

1 Answer 1


I finally figured it out. There was a 3rd party DLL in the project called safileup.dll that was being used to upload files on the application. Removing that file from the bin directory fixed my hanging issues.

The dll in question was softartisans fileup. We will be discontinuing use of this add on.

  • 1
    Moral of the story: Make sure 3rd party add ons are compatible in your new environment first!
    – Fake
    Jun 30, 2010 at 15:56
  • I had exactly same issue and it was the safileup.dll :)
    – McLovin
    Nov 1, 2010 at 22:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .