8

I'm getting the following error when i try and install MSSQL 2008 on Windows Server Standard 2008 R2:

desc

2
  • You don't say what your Windows locale settings are. Please provide more information. – user3914 Jun 30 '10 at 21:11
  • 1
    I had the same problem, my media was French(France) but my OS region was French(Canada). I changed the region from French(Canada) to French(France) and it worked. – MusicAndCode Sep 3 '15 at 14:34
13

I found this workaround from MS connect website:

Go to Control Panel, Regional Settings and change the "Format" language on the first section; close window, re-enter and change format back to your locale. Launch setup of SQL Server and now it should work.

Check out the other workarounds mentioned in the same site.

Also if you give more info about your environment more people will be able to help you.

1

I'm resurrecting this rather old answer because I stumbled upon this issue today with Windows Server 2012-R2 and SQL Server 2017, meaning that it's still valid :)

Surprisingly enough, although I had the same identical popup window shown by the OP, my scenario didn't have anything to do with the Language & Region settings: I just had to delete some old SQL Server setup files that were still present in the %ProgramFiles%\Microsoft SQL Server\NNN folder (where NNN is 140 for SQL Server 2017, 130 for SQL Server 2016 and so on): as soon as I did that, the issue was fixed for good and I was able to install SQL Server 2017 without issues.

For additional info about this issue, read this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.