I am having an issue on my Windows Server 2008 "Sql Server".

When I access Disk Management, the UI hangs on "Loading disk configuration information"

When I run diskpart it does nothing after showing the server name.

I NEED to expand my secondary drive because I need to move my database files off the C drive (I have like 4 gb free space).

EDIT: In the past, I used my domain controller to access disk management remotely to expand a drive and it worked on a different machine. On this one, however, the disk management hands even on the DC.

Any ideas?

  • out of interest were you using mcafee? – user129064 Jul 20 '12 at 11:21

Try the following:

  • Run a chkdsk /f on all disks in the system to make sure they are ok.
  • Open up services.msc and make sure the following services are started: Remote Procedure Call (RPC), Plug and Play and Virtual Disk.
  • I don't know why, but it just worked one day when we were in crisis aversion mode. We never found out what was going on or why it suddenly worked. Updates to the underlying linux, changes in settings, or maybe some vooodoo magic seemed to cure it. Thanks for your suggestions Matthew. – Josh Sep 3 '10 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.