0

I am trying to install SQL Server 2008 R1 on a Windows 7 Enterprise Edition machine...I have tried multiple times and each time I get an access denied error for the Database Engine, Replication and Full Text Search.

My account has admin privileges and I have also tried the local admin account for my machine. Any ideas why I keep getting the Access Denied? I was getting it when I was trying to install SQL Server 2008 R2 express edition as well.

Thanks,

S

migrated from stackoverflow.com Jul 3 '10 at 6:31

This question came from our site for professional and enthusiast programmers.

  • are you sure the service is running? – Tahbaza Jul 2 '10 at 0:46
3

Although I've not attempted this on Windows 7, I'm assuming the issue is the same as I've encountered on Windows Server 2008 R2. This is happening due to the Windows UAC. Run the installation by right clicking (or perhaps shift-right click) on the executable and choose "Run as Administrator". This has been successful for me thus far . . .

  • Thanks Scott....that was part of the issue. There were also some priveleges that support hadn't provided my account. – scarpacci Jul 3 '10 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy